summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Limansky <mike.limansky@gmail.com>2023-01-21 01:11:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-02-05 10:30:36 +0200
commitb544c7f4a33076eff75f39029bb56b0bfbe1f5c3 (patch)
tree1e3dec125a682a2893a568f78564424c102495e2 /app-emulation
parentdev-util/rt-tests: drop 2.4 (diff)
downloadgentoo-b544c7f4a33076eff75f39029bb56b0bfbe1f5c3.tar.gz
gentoo-b544c7f4a33076eff75f39029bb56b0bfbe1f5c3.tar.bz2
gentoo-b544c7f4a33076eff75f39029bb56b0bfbe1f5c3.zip
app-emulation/vagrant: Support ruby30
Closes: https://bugs.gentoo.org/891127 Signed-off-by: Mikhail Limansky <mike.limansky@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29193 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vagrant/files/vagrant.in2
-rw-r--r--app-emulation/vagrant/vagrant-2.2.18-r1.ebuild4
-rw-r--r--app-emulation/vagrant/vagrant-2.2.19-r1.ebuild4
-rw-r--r--app-emulation/vagrant/vagrant-2.2.19.ebuild4
4 files changed, 7 insertions, 7 deletions
diff --git a/app-emulation/vagrant/files/vagrant.in b/app-emulation/vagrant/files/vagrant.in
index 5760b56839c8..d77c39d06045 100644
--- a/app-emulation/vagrant/files/vagrant.in
+++ b/app-emulation/vagrant/files/vagrant.in
@@ -4,7 +4,7 @@
# Vagrant installation directory. This sets up proper environmental variables
# so that everything loads and compiles to proper directories.
-for r in ruby27 ruby26 ruby25; do
+for r in ruby30 ruby27 ruby26; do
# not all ruby versions are guaranteed to be installed
if ! command -v "${r}" >/dev/null 2>&1; then
continue
diff --git a/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
index 3d8077b15ec7..ddb8fa90f82a 100644
--- a/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
+++ b/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
diff --git a/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild
index bb916546e995..b9dfc5890e75 100644
--- a/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild
+++ b/app-emulation/vagrant/vagrant-2.2.19-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
diff --git a/app-emulation/vagrant/vagrant-2.2.19.ebuild b/app-emulation/vagrant/vagrant-2.2.19.ebuild
index 064cab439b20..3dde73808665 100644
--- a/app-emulation/vagrant/vagrant-2.2.19.ebuild
+++ b/app-emulation/vagrant/vagrant-2.2.19.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"