summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-17 18:21:22 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-17 18:27:42 +0200
commitb8bb49d90f7fd0eabfd46d354cc524b5a356bc19 (patch)
tree798d72d07529cd2b4784e4c5d8efb20ba2f91d6e /app-emulation
parentapp-metrics/redis_exporter: Version bump to 0.20.2 (diff)
downloadgentoo-b8bb49d90f7fd0eabfd46d354cc524b5a356bc19.tar.gz
gentoo-b8bb49d90f7fd0eabfd46d354cc524b5a356bc19.tar.bz2
gentoo-b8bb49d90f7fd0eabfd46d354cc524b5a356bc19.zip
app-emulation/reg: Version bump to 0.15.4
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/reg/Manifest1
-rw-r--r--app-emulation/reg/reg-0.15.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/reg/Manifest b/app-emulation/reg/Manifest
index bb92968610dd..9f29aaeadd89 100644
--- a/app-emulation/reg/Manifest
+++ b/app-emulation/reg/Manifest
@@ -1,3 +1,4 @@
DIST reg-0.13.3.tar.gz 5396000 BLAKE2B c5fa658010cb5c1cc21d7edfc1b18fac8c65cf2bd3c6de213ab238aabcb1377096172b5484a92f18a04f9ef4c01124dcfcfd4e6eabaf9f9a9b272c6f1f1fc482 SHA512 aefe0e5d3b1a02d54e67a4c7892e6b6c7581793f9e45995933200125c275e38701ad25b772c4541714f72ad1b43865e484bd062e40edbb7ed5faf2a572c224a1
DIST reg-0.13.4.tar.gz 5401627 BLAKE2B 278462ff66917833feb9a660b39f9826afe1b71f7a75dad07f3673bd5ba63496152aa70147649ddf9d2266cbad3903ba3a4bbe4a7def76a932ea45131bdda8c5 SHA512 f8a1a52824b64cc252a5cd4f6c18d8cf73c88170342f0bab61664f5cdb50295510182c3c15afdfa02c1eae8d299e347a78b47d171ca275c01ecfd9228323c872
DIST reg-0.14.1.tar.gz 5401469 BLAKE2B 858c699b15e2222685e114d7c7619424dde6eb87cff08f79de621d5c0d35303b0e8f10981b5c0839633eebbb223658189369899f1a3e15bbdf1cf10dffcf88cf SHA512 2904b5da02cd5f0d98447aa86e36e13f96b1e0ef8f81f97d3fd801e3d477909c6d893db8af4e84591a4630633a698b8a21e673d5abbc169812ebd857615b8401
+DIST reg-0.15.4.tar.gz 4052737 BLAKE2B 34bc68d3cb161bbea02bfc0ed142cb764f2db64610ac7b2b92130cfc838cfa4fde4794da9fd2d38a9bb73e994cf386ac9f50beaa4435b88cf034a4f4d0b648cc SHA512 d5948b095c310c2697a2f7b80a342af6949e4cb66c521cdb370a6fbead7424d729057fe71952291ee1ed82717cd7bb29141f6a2f85c946e33fd96da1c17912dd
diff --git a/app-emulation/reg/reg-0.15.4.ebuild b/app-emulation/reg/reg-0.15.4.ebuild
new file mode 100644
index 000000000000..2695cd240b3f
--- /dev/null
+++ b/app-emulation/reg/reg-0.15.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/reg"
+GIT_COMMIT="8c930c585418564a4ce472fbbfccb8c5741c2520"
+ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc src/${EGO_PN}/README.md
+ insinto /usr/share/${PN}
+ doins -r src/${EGO_PN}/server/*
+}