summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-05-13 17:54:01 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-05-13 17:54:57 -0500
commitbf264b032424c6adbbdc7ffc8580789f89dce206 (patch)
tree2f1b9cc5d296dc1ee05ad023dd6042c817f0dbbb /app-emulation
parentapp-emulation/spice: fix dep on media-libs/gst-plugins-base, bug #618272 (diff)
downloadgentoo-bf264b032424c6adbbdc7ffc8580789f89dce206.tar.gz
gentoo-bf264b032424c6adbbdc7ffc8580789f89dce206.tar.bz2
gentoo-bf264b032424c6adbbdc7ffc8580789f89dce206.zip
app-emulation/spice: ebuild maintenance
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/spice-0.13.3-r1.ebuild6
-rw-r--r--app-emulation/spice/spice-9999.ebuild33
2 files changed, 22 insertions, 17 deletions
diff --git a/app-emulation/spice/spice-0.13.3-r1.ebuild b/app-emulation/spice/spice-0.13.3-r1.ebuild
index f628d32d39b5..f0fcaba58002 100644
--- a/app-emulation/spice/spice-0.13.3-r1.ebuild
+++ b/app-emulation/spice/spice-0.13.3-r1.ebuild
@@ -31,8 +31,7 @@ RDEPEND="
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
- )
-"
+ )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
>=app-emulation/spice-protocol-0.12.12
@@ -41,8 +40,7 @@ DEPEND="${RDEPEND}
>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
')
- smartcard? ( app-emulation/qemu[smartcard] )
-"
+ smartcard? ( app-emulation/qemu[smartcard] )"
PATCHES=(
"${FILESDIR}"/${PN}-0.13.3-skip_faulty_lz4_check.patch
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index 6d7fac8ab1aa..e26a09ac6848 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit eutils git-r3 python-any-r1 autotools readme.gentoo-r1
+inherit autotools eutils git-r3 ltprune python-any-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="SPICE server"
HOMEPAGE="http://spice-space.org/"
@@ -17,6 +16,7 @@ SLOT="0"
KEYWORDS=""
IUSE="libressl lz4 sasl smartcard static-libs gstreamer"
+# the libspice-server only uses the headers of libcacard
RDEPEND="
>=dev-libs/glib-2.22:2[static-libs(+)?]
>=media-libs/celt-0.5.1.1:0.5.1[static-libs(+)?]
@@ -24,22 +24,24 @@ RDEPEND="
sys-libs/zlib[static-libs(+)?]
virtual/jpeg:0=[static-libs(+)?]
>=x11-libs/pixman-0.17.7[static-libs(+)?]
- !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
- libressl? ( dev-libs/libressl[static-libs(+)?] )
- lz4? ( app-arch/lz4 )
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)?] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)?] )
+ lz4? ( app-arch/lz4:0=[static-libs(+)?] )
smartcard? ( >=app-emulation/libcacard-0.1.2 )
sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
- gstreamer? ( media-libs/gstreamer:1.0 )"
-
-DEPEND="
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
=app-emulation/spice-protocol-9999
virtual/pkgconfig
$(python_gen_any_dep '
>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
')
- smartcard? ( app-emulation/qemu[smartcard] )
- ${RDEPEND}"
+ smartcard? ( app-emulation/qemu[smartcard] )"
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
@@ -52,6 +54,7 @@ pkg_setup() {
src_prepare() {
default
+
eautoreconf
}
@@ -66,7 +69,7 @@ src_configure() {
$(use_enable lz4)
$(use_with sasl)
$(use_enable smartcard)
- $(usex gstreamer "1.0" "no")
+ --enable-gstreamer=$(usex gstreamer "1.0" "no")
--enable-celt051
--disable-gui
"
@@ -87,3 +90,7 @@ src_install() {
use static-libs || prune_libtool_files
readme.gentoo_create_doc
}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}