summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2020-07-28 17:32:04 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-16 11:00:57 +0300
commitc36a73546fb51cf33dcdd1fab2444d4da239665f (patch)
tree082b33324dfc4152e865eae925b0ee7849f7bab5 /app-emulation
parentapp-emulation/libspectrum: avoid /usr/lib in the link command line (diff)
downloadgentoo-c36a73546fb51cf33dcdd1fab2444d4da239665f.tar.gz
gentoo-c36a73546fb51cf33dcdd1fab2444d4da239665f.tar.bz2
gentoo-c36a73546fb51cf33dcdd1fab2444d4da239665f.zip
app-emulation/fuse: avoid /usr/lib in the link command line
Closes: https://bugs.gentoo.org/734182 Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fuse/files/remove-local-prefix.patch18
-rw-r--r--app-emulation/fuse/fuse-1.5.6.ebuild13
-rw-r--r--app-emulation/fuse/fuse-1.5.7.ebuild13
3 files changed, 42 insertions, 2 deletions
diff --git a/app-emulation/fuse/files/remove-local-prefix.patch b/app-emulation/fuse/files/remove-local-prefix.patch
new file mode 100644
index 000000000000..61bf33a1adc7
--- /dev/null
+++ b/app-emulation/fuse/files/remove-local-prefix.patch
@@ -0,0 +1,18 @@
+diff -Naur fuse-1.5.7/configure.ac fuse-1.5.7-patched/configure.ac
+--- fuse-1.5.7/configure.ac 2018-12-09 13:06:11.000000000 +0100
++++ fuse-1.5.7-patched/configure.ac 2020-07-28 17:02:33.678546857 +0200
+@@ -110,14 +110,6 @@
+ AX_STRINGS_STRCASECMP
+ fi
+
+-dnl Allow the user to say that various libraries are in one place
+-AC_ARG_WITH(local-prefix,
+-[ --with-local-prefix=PFX local libraries installed in PFX (optional)],
+-CPPFLAGS="$CPPFLAGS -I$withval/include"; LDFLAGS="$LDFLAGS -L$withval/lib",
+-if test "$prefix" != "NONE"; then
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"; LDFLAGS="$LDFLAGS -L$prefix/lib"
+-fi)
+-
+ dnl Check that libspectrum is available and that it is new enough
+ PKG_CHECK_MODULES([LIBSPECTRUM], [libspectrum >= 1.4.0])
+
diff --git a/app-emulation/fuse/fuse-1.5.6.ebuild b/app-emulation/fuse/fuse-1.5.6.ebuild
index 0e1754ea0792..ffc3cfaeb973 100644
--- a/app-emulation/fuse/fuse-1.5.6.ebuild
+++ b/app-emulation/fuse/fuse-1.5.6.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
@@ -35,6 +37,15 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog README THANKS )
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--without-win32
diff --git a/app-emulation/fuse/fuse-1.5.7.ebuild b/app-emulation/fuse/fuse-1.5.7.ebuild
index 0e1754ea0792..ffc3cfaeb973 100644
--- a/app-emulation/fuse/fuse-1.5.7.ebuild
+++ b/app-emulation/fuse/fuse-1.5.7.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
HOMEPAGE="http://fuse-emulator.sourceforge.net"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
@@ -35,6 +37,15 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog README THANKS )
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--without-win32