summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2016-08-07 16:01:31 +0200
committerLuca Barbato <lu_zero@gentoo.org>2016-08-07 16:01:31 +0200
commitccc9ac6f494435c750ec71d67d09d41739e54c35 (patch)
tree6ff9b49e269f927d7b9b0a8a06d749b251309d76 /app-emulation
parentpackage.mask: Mask new xfce-base/exo due to major session handling issues (diff)
downloadgentoo-ccc9ac6f494435c750ec71d67d09d41739e54c35.tar.gz
gentoo-ccc9ac6f494435c750ec71d67d09d41739e54c35.tar.bz2
gentoo-ccc9ac6f494435c750ec71d67d09d41739e54c35.zip
app-emulation/qemu: Drop a -Werror when it could cause a false positive
The check code could trigger recent compiler warnings. Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/files/qemu-2.6.0-glib-size_t.patch11
-rw-r--r--app-emulation/qemu/qemu-2.6.0.ebuild2
2 files changed, 12 insertions, 1 deletions
diff --git a/app-emulation/qemu/files/qemu-2.6.0-glib-size_t.patch b/app-emulation/qemu/files/qemu-2.6.0-glib-size_t.patch
new file mode 100644
index 000000000000..5fd678c7f134
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-2.6.0-glib-size_t.patch
@@ -0,0 +1,11 @@
+--- a/configure 2016-08-07 15:50:20.386687733 +0200
++++ b/configure 2016-08-07 15:53:55.489691690 +0200
+@@ -2967,7 +2967,7 @@
+ }
+ EOF
+
+-if ! compile_prog "-Werror $CFLAGS" "$LIBS" ; then
++if ! compile_prog "$CFLAGS" "$LIBS" ; then
+ error_exit "sizeof(size_t) doesn't match GLIB_SIZEOF_SIZE_T."\
+ "You probably need to set PKG_CONFIG_LIBDIR"\
+ "to point to the right pkg-config files for your"\
diff --git a/app-emulation/qemu/qemu-2.6.0.ebuild b/app-emulation/qemu/qemu-2.6.0.ebuild
index 8f9ff83c3e56..e45a5d19f2c3 100644
--- a/app-emulation/qemu/qemu-2.6.0.ebuild
+++ b/app-emulation/qemu/qemu-2.6.0.ebuild
@@ -334,7 +334,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.5.0-cflags.patch
epatch "${FILESDIR}"/${PN}-2.5.0-sysmacros.patch
epatch "${FILESDIR}"/${PN}-2.6.0-crypto-static.patch
-
+ epatch "${FILESDIR}"/${PN}-2.6.0-glib-size_t.patch
# Fix ld and objcopy being called directly
tc-export AR LD OBJCOPY