summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-10 16:26:17 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-10 16:26:55 -0700
commitcec1c0dc8c45379e67a50019333fe65743f60c7b (patch)
tree23e04effdf199c1add41078d90b203c50cf0029f /app-emulation
parentpackage.deprecated: add dev-perl/Gtk2-SourceView2 (diff)
downloadgentoo-cec1c0dc8c45379e67a50019333fe65743f60c7b.tar.gz
gentoo-cec1c0dc8c45379e67a50019333fe65743f60c7b.tar.bz2
gentoo-cec1c0dc8c45379e67a50019333fe65743f60c7b.zip
app-emulation/docker: add ppc64 buildmode patch
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker/docker-20.10.7.ebuild5
-rw-r--r--app-emulation/docker/files/ppc64-buildmode.patch30
2 files changed, 34 insertions, 1 deletions
diff --git a/app-emulation/docker/docker-20.10.7.ebuild b/app-emulation/docker/docker-20.10.7.ebuild
index 6636481017d9..611164ae3abc 100644
--- a/app-emulation/docker/docker-20.10.7.ebuild
+++ b/app-emulation/docker/docker-20.10.7.ebuild
@@ -55,7 +55,10 @@ RESTRICT="installsources strip test"
S="${WORKDIR}/${P}/src/${EGO_PN}"
# https://bugs.gentoo.org/748984 https://github.com/etcd-io/etcd/pull/12552
-PATCHES=( "${FILESDIR}/etcd-F_OFD_GETLK-fix.patch" )
+PATCHES=(
+ "${FILESDIR}/etcd-F_OFD_GETLK-fix.patch"
+ "${FILESDIR}/ppc64-buildmode.patch"
+)
# see "contrib/check-config.sh" from upstream's sources
CONFIG_CHECK="
diff --git a/app-emulation/docker/files/ppc64-buildmode.patch b/app-emulation/docker/files/ppc64-buildmode.patch
new file mode 100644
index 000000000000..f16756e85041
--- /dev/null
+++ b/app-emulation/docker/files/ppc64-buildmode.patch
@@ -0,0 +1,30 @@
+From c4135e37e54a6480abfe18746f227f05cb9269ab Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Thu, 10 Jun 2021 16:19:22 -0700
+Subject: [PATCH] don't use buildmode=pie on ppc64
+
+It's already omitted for ppc64 in
+hack/dockerfile/install/install.sh
+not using wildcard, because GOARCH=ppc64le supports pie
+
+Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
+---
+ hack/make/.binary | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/hack/make/.binary b/hack/make/.binary
+index 5ea3e373f2..7a911de15a 100644
+--- a/hack/make/.binary
++++ b/hack/make/.binary
+@@ -70,7 +70,7 @@ hash_files() {
+
+ # -buildmode=pie is not supported on Windows and Linux on mips and riscv64.
+ case "$(go env GOOS)/$(go env GOARCH)" in
+- windows/* | linux/mips* | linux/riscv*) ;;
++ windows/* | linux/mips* | linux/riscv* | linux/ppc64) ;;
+
+ *)
+ BUILDFLAGS+=("-buildmode=pie")
+--
+2.32.0
+