summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-22 15:59:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-22 16:31:13 -0400
commitd8c7ecb8fbbdbcbef6b9804e93b0d0669e0f28fc (patch)
tree5424745ee24ea77e0fde7a1b68916bffa115cb25 /app-emulation
parentapp-emulation/wine-staging: drop 9.3, 9.4.1 (diff)
downloadgentoo-d8c7ecb8fbbdbcbef6b9804e93b0d0669e0f28fc.tar.gz
gentoo-d8c7ecb8fbbdbcbef6b9804e93b0d0669e0f28fc.tar.bz2
gentoo-d8c7ecb8fbbdbcbef6b9804e93b0d0669e0f28fc.zip
app-emulation/wine-staging: "fix" build with gcc-14
All versions currently broken due to the staging patchset itself (>=vanilla-9 and proton-9.0.9999 are fine). Given amount of wine variants and versions, going for the lazy "fix" in these for now. Given the active development, imagine will be able to cleanup later. Closes: https://bugs.gentoo.org/919758 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-9.0.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9.5.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9.6.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9.7.ebuild5
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild5
5 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9.0.ebuild b/app-emulation/wine-staging/wine-staging-9.0.ebuild
index 7a0bdfdd539c..537675f10ba0 100644
--- a/app-emulation/wine-staging/wine-staging-9.0.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.0.ebuild
@@ -337,6 +337,11 @@ src_configure() {
strip-unsupported-flags
fi
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # staging patchset is messier and would rather not have to worry
+ # about it (try to remove on bump now and then, bug #919758)
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
if use mingw; then
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
diff --git a/app-emulation/wine-staging/wine-staging-9.5.ebuild b/app-emulation/wine-staging/wine-staging-9.5.ebuild
index ff73fe1caa6e..08b56968b3ac 100644
--- a/app-emulation/wine-staging/wine-staging-9.5.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.5.ebuild
@@ -337,6 +337,11 @@ src_configure() {
strip-unsupported-flags
fi
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # staging patchset is messier and would rather not have to worry
+ # about it (try to remove on bump now and then, bug #919758)
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
if use mingw; then
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
diff --git a/app-emulation/wine-staging/wine-staging-9.6.ebuild b/app-emulation/wine-staging/wine-staging-9.6.ebuild
index e7ecd6c1b120..2c9f8fc4ef2a 100644
--- a/app-emulation/wine-staging/wine-staging-9.6.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.6.ebuild
@@ -332,6 +332,11 @@ src_configure() {
strip-unsupported-flags
fi
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # staging patchset is messier and would rather not have to worry
+ # about it (try to remove on bump now and then, bug #919758)
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
if use mingw; then
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
diff --git a/app-emulation/wine-staging/wine-staging-9.7.ebuild b/app-emulation/wine-staging/wine-staging-9.7.ebuild
index e7ecd6c1b120..2c9f8fc4ef2a 100644
--- a/app-emulation/wine-staging/wine-staging-9.7.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.7.ebuild
@@ -332,6 +332,11 @@ src_configure() {
strip-unsupported-flags
fi
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # staging patchset is messier and would rather not have to worry
+ # about it (try to remove on bump now and then, bug #919758)
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
if use mingw; then
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index e7ecd6c1b120..2c9f8fc4ef2a 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -332,6 +332,11 @@ src_configure() {
strip-unsupported-flags
fi
+ # >=wine-vanilla-9 has proper fixes and builds with gcc-14, but
+ # staging patchset is messier and would rather not have to worry
+ # about it (try to remove on bump now and then, bug #919758)
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
if use mingw; then
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}