summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-25 16:11:39 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-25 16:13:14 +0100
commitf409dc9bb683e0d22e553332674b4c8fc55599a3 (patch)
treed095e48a14c3c31304b5ced9fc00529ab6236d75 /app-emulation
parentsys-cluster/keepalived: bump to 2.0.20, drop old (diff)
downloadgentoo-f409dc9bb683e0d22e553332674b4c8fc55599a3.tar.gz
gentoo-f409dc9bb683e0d22e553332674b4c8fc55599a3.tar.bz2
gentoo-f409dc9bb683e0d22e553332674b4c8fc55599a3.zip
app-emulation/docker-compose: 1.25.3
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-compose/Manifest1
-rw-r--r--app-emulation/docker-compose/docker-compose-1.25.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index c5f61faece31..f31bb4ec2363 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -3,3 +3,4 @@ DIST docker-compose-1.24.1.tar.gz 307749 BLAKE2B 7ded0a4b82a7a9beb9de38752f38998
DIST docker-compose-1.25.0.tar.gz 320048 BLAKE2B a0615c9d81f897f551d664799e2a7cd4d72c3e0b70ceb0ff9bfb533a81799d2d524824ead27bff2391c5e98fc34430fb2ba724bba663ece66417ac72181241f0 SHA512 38be153a8ba1bf1a4a5c63dc794db3344c93c0819fba0c38feb791067e0aa72142205e4255b5fd31bf2f8159dfa04cde09fdcdabe0511bc0e2865974dff5433d
DIST docker-compose-1.25.1.tar.gz 321627 BLAKE2B 9056b0e359ff6cccba16b7ea5fc96de363f242103c48d15e3ed19ed5291878f7a5c81f99b7fd3eff46eaff5b271e883125ab02ff22bf592c4a5dd12792790fdc SHA512 5e58edd3364caecc9b6ec0e92e629e624694e42f96da836378648918dfaa41ddc0c99b107f2d3f11d1dd6ab86a516a7b2da3783b542623440d8c0c6628c05020
DIST docker-compose-1.25.2.tar.gz 306196 BLAKE2B 6bf9c1ae14b25f41a7b3893f5ddc5b654743b29eb17c3d1b23e47d004e8e3feaf021b67c2419632faa6b11713ad1bd956b9f756e36fcd8efc7e60404a1de53a7 SHA512 ce045c6af233d6d03fd26100bce836444abb3022d6661ac6073cd8c6b8ed1cc0bbef9cbfad73672c8d3b6f3a12ee98e6e60c5f1b90360f778d5fa8d18e00179e
+DIST docker-compose-1.25.3.tar.gz 306220 BLAKE2B 503a76d51ff36e7a91030f240c8b795383f399472517056e3d586ddb72c31dd02fed51474e7716e4f43f801a10160e271ed695c5defa6a2d3e1be647d9f0d33b SHA512 92c7bb2adf5fd033add0bfe92634c04d0acb69846daabb215eea696d396fbcc13ffa175173544c4e2a3ae0c0ec0ac81526b6cef68cdcfe0eecec6ac894c6f8f2
diff --git a/app-emulation/docker-compose/docker-compose-1.25.3.ebuild b/app-emulation/docker-compose/docker-compose-1.25.3.ebuild
new file mode 100644
index 000000000000..fa7ef8bfb516
--- /dev/null
+++ b/app-emulation/docker-compose/docker-compose-1.25.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Multi-container orchestration for Docker"
+HOMEPAGE="https://github.com/docker/compose"
+SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-shutil_get_terminal_size-1.0.0[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/subprocess32-3.5.4[${PYTHON_USEDEP}]' 'python2_7' )"
+
+DEPEND="${RDEPEND}
+ test? (
+ <dev-python/pytest-4[${PYTHON_USEDEP}]
+ dev-python/ddt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
+ )"
+
+S="${WORKDIR}/compose-${PV}"
+
+PATCHES=(
+ # Bug #679968 -- https://bugs.gentoo.org/679968
+ # Bug #681002 -- https://bugs.gentoo.org/681002
+ "${FILESDIR}"/${PN}-1.25.2-setup-py.patch
+)
+
+src_prepare() {
+ # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
+ sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
+
+ default
+}
+
+python_test() {
+ distutils_install_for_testing
+ ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp contrib/completion/bash/docker-compose ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/*
+
+ distutils-r1_python_install_all
+}