summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2018-05-28 11:59:16 -0400
committerNick Sarnie <sarnex@gentoo.org>2018-05-28 11:59:16 -0400
commitfc37e17458b060697c39b548e89f610cf9c20220 (patch)
treeb926d41446f9df05af01c4e8913527f43aa2517f /app-emulation
parentapp-emulation/wine-d3d9: Sync with ::wine (diff)
downloadgentoo-fc37e17458b060697c39b548e89f610cf9c20220.tar.gz
gentoo-fc37e17458b060697c39b548e89f610cf9c20220.tar.bz2
gentoo-fc37e17458b060697c39b548e89f610cf9c20220.zip
app-emulation/wine-staging: Sync with ::wine
Add vkd3d USE Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/metadata.xml1
-rw-r--r--app-emulation/wine-staging/wine-staging-3.9.ebuild4
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild4
3 files changed, 7 insertions, 2 deletions
diff --git a/app-emulation/wine-staging/metadata.xml b/app-emulation/wine-staging/metadata.xml
index de9b63d08677..da4de45bfb76 100644
--- a/app-emulation/wine-staging/metadata.xml
+++ b/app-emulation/wine-staging/metadata.xml
@@ -42,6 +42,7 @@ This variant of the Wine packaging includes the Wine-Staging patchset.
<flag name="staging">Apply Wine-Staging patches for advanced feature support that haven't made it into upstream Wine yet</flag>
<flag name="themes">Support GTK+:3 window theming through Wine-Staging</flag>
<flag name="udev">Use <pkg>virtual/libudev</pkg> to provide plug and play support</flag>
+ <flag name="vkd3d">Use <pkg>app-emulation/vkd3d</pkg> to provide Direct3D 12 support</flag>
<flag name="vulkan">Enable Vulkan drivers</flag>
</use>
<upstream>
diff --git a/app-emulation/wine-staging/wine-staging-3.9.ebuild b/app-emulation/wine-staging/wine-staging-3.9.ebuild
index 7ba4e022173c..4873ea014bd1 100644
--- a/app-emulation/wine-staging/wine-staging-3.9.ebuild
+++ b/app-emulation/wine-staging/wine-staging-3.9.ebuild
@@ -44,7 +44,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner sdl selinux +ssl staging test themes +threads +truetype udev +udisks v4l vaapi vulkan +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner sdl selinux +ssl staging test themes +threads +truetype udev +udisks v4l vaapi vkd3d vulkan +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -112,6 +112,7 @@ COMMON_DEPEND="
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
vaapi? ( x11-libs/libva[X,${MULTILIB_USEDEP}] )
+ vkd3d? ( app-emulation/vkd3d[${MULTILIB_USEDEP}] )
vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )
xcomposite? ( x11-libs/libXcomposite[${MULTILIB_USEDEP}] )
xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
@@ -467,6 +468,7 @@ multilib_src_configure() {
$(use_with truetype freetype)
$(use_with udev)
$(use_with v4l)
+ $(use_with vkd3d)
$(use_with vulkan)
$(use_with X x)
$(use_with X xfixes)
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 7ba4e022173c..4873ea014bd1 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -44,7 +44,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner sdl selinux +ssl staging test themes +threads +truetype udev +udisks v4l vaapi vulkan +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner sdl selinux +ssl staging test themes +threads +truetype udev +udisks v4l vaapi vkd3d vulkan +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -112,6 +112,7 @@ COMMON_DEPEND="
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
vaapi? ( x11-libs/libva[X,${MULTILIB_USEDEP}] )
+ vkd3d? ( app-emulation/vkd3d[${MULTILIB_USEDEP}] )
vulkan? ( media-libs/vulkan-loader[${MULTILIB_USEDEP}] )
xcomposite? ( x11-libs/libXcomposite[${MULTILIB_USEDEP}] )
xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
@@ -467,6 +468,7 @@ multilib_src_configure() {
$(use_with truetype freetype)
$(use_with udev)
$(use_with v4l)
+ $(use_with vkd3d)
$(use_with vulkan)
$(use_with X x)
$(use_with X xfixes)