summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-04-12 11:31:54 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-04-17 11:40:50 -0400
commit96fb4f98f5c23f3454f501efae669f7584f98568 (patch)
treecf99e706be3d9ff9662315021da7caee47302026 /app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild
parentmedia-libs/mesa: Version bump to 17.0.4 (diff)
downloadgentoo-96fb4f98f5c23f3454f501efae669f7584f98568.tar.gz
gentoo-96fb4f98f5c23f3454f501efae669f7584f98568.tar.bz2
gentoo-96fb4f98f5c23f3454f501efae669f7584f98568.zip
app-eselect/eselect-postgresql: Bug Fixes and Enhancements
Version 2.0 is capable of handling the upcoming change in versioning for PostgreSQL. Links to pkg-config files of the selected slot are now created and managed by this module. Links to the man pages for the selected slot are now created and managed by this module. Slot-specific man pages are handled by the ebuilds. This version is stateless. It does not need to store any files to determine which slots and links are in use. Bugs: 597564, 512236, 564512 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild')
-rw-r--r--app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild b/app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild
new file mode 100644
index 000000000000..78161c8e52de
--- /dev/null
+++ b/app-eselect/eselect-postgresql/eselect-postgresql-2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Utility to select the default PostgreSQL slot"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~titanofold/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins postgresql.eselect
+
+ dosym /usr/bin/eselect /usr/bin/postgresql-config
+}
+
+pkg_postinst() {
+ postgresql-config update
+}