summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2016-01-26 22:53:29 +0100
committerKristian Fiskerstrand <k_f@gentoo.org>2016-01-26 22:53:44 +0100
commit67ec84575e507760da831a9f88c17d26be9d898a (patch)
treed43d09062b1bace8ceec7f6059f33dda87bb788c /app-eselect
parentnet-analyzer/metasploit: adding ~arm for 4.11.7 (diff)
downloadgentoo-67ec84575e507760da831a9f88c17d26be9d898a.tar.gz
gentoo-67ec84575e507760da831a9f88c17d26be9d898a.tar.bz2
gentoo-67ec84575e507760da831a9f88c17d26be9d898a.zip
app-eselect/eselect-pinentry: Add pinentry-tty as an option
Bug: 572750 Package-Manager: portage-2.2.27
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild23
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.713
2 files changed, 36 insertions, 0 deletions
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
new file mode 100644
index 000000000000..f5d475a77606
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+S=${FILESDIR}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7
new file mode 100644
index 000000000000..37db8691804f
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7
@@ -0,0 +1,13 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="ssuominen@gentoo.org"
+VERSION="0.7"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=( pinentry-gnome3 pinentry-qt pinentry-gtk-2 pinentry-qt4 pinentry-curses pinentry-tty )
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink