summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-15 21:33:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-15 21:37:13 +0200
commite08f675d1d6d66b806a8010ee6114baae4b7c864 (patch)
treed76b33169240e3df13b8168b0d1d956569c20716 /app-eselect
parentcargo.eclass: Really set dependencies. (diff)
downloadgentoo-e08f675d1d6d66b806a8010ee6114baae4b7c864.tar.gz
gentoo-e08f675d1d6d66b806a8010ee6114baae4b7c864.tar.bz2
gentoo-e08f675d1d6d66b806a8010ee6114baae4b7c864.zip
app-eselect/eselect-repository: Bump to v6
Bump to v6 which includes fix for missing cache error when adding new repository as the first action post-install. Closes: https://bugs.gentoo.org/667884 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-repository/Manifest1
-rw-r--r--app-eselect/eselect-repository/eselect-repository-6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/Manifest b/app-eselect/eselect-repository/Manifest
index 3069b62380dd..b4eb48811b79 100644
--- a/app-eselect/eselect-repository/Manifest
+++ b/app-eselect/eselect-repository/Manifest
@@ -1,2 +1,3 @@
DIST eselect-repository-4.tar.gz 5535 BLAKE2B 4dce6c0136ec9394c9bf4128ec26ab67260d4b96a165825ae7b15b8476d10d23fcc5190946fc54013d6eb8e4f18988b07df4c849ba50844571986a6823511547 SHA512 0d3c204d73bb4314bc24fdf6cd837f2a56ac00d1d11fbec7f072af874bc468777676bba40e0cc17553f6dec7a907f10865f9c356a6390372e0734173465ac483
DIST eselect-repository-5.tar.gz 5607 BLAKE2B cc007474b51873b7fa7f9c56572be717e7b8dff0d46c21d838911bcf9ecea99549da8e9f2d63c8101c0bc9c2ca230bfaba46f8bd770488d6566a62b2ac2ab0a6 SHA512 b5cf1701cc1d0cb50afcb9403f5c6f41223240891029f51ff899144eecee6fa3d7cfad23c477fae23733f9005413facd2cb8e9e1dea70931abc691a225fa83b4
+DIST eselect-repository-6.tar.gz 5605 BLAKE2B 4a6dbb3f573cb1c4e212d02d011e79d8522828b8928bf28016b616c8eefd3beb08db8b555728d4e7f83473f2d36395eb1e2f1d8d21ccd5817e38a5d555cf6f09 SHA512 02ca2d66a6cfe4c68dea780440bf7fd431c575e535139a43c2b6201e833e43d174772486c97dc4154fc2d813935079d36c116ee907db115f7cb281db3d72add7
diff --git a/app-eselect/eselect-repository/eselect-repository-6.ebuild b/app-eselect/eselect-repository/eselect-repository-6.ebuild
new file mode 100644
index 000000000000..06ccc47c631d
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ dev-python/lxml[${PYTHON_USEDEP}]
+ net-misc/wget"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ keepdir /var/db/repos
+ einstalldocs
+}