summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-03-21 12:38:27 +0100
committerMichael Weber <xmw@gentoo.org>2016-03-21 12:39:00 +0100
commitae6d6ffd8eed52b9ee9c484c6674b8e2e1d236ca (patch)
tree139d9efab39ec96104c250456c1fda3d19c2098e /app-forensics/chkrootkit/chkrootkit-0.50.ebuild
parentsci-mathematics/normaliz: remove old (diff)
downloadgentoo-ae6d6ffd8eed52b9ee9c484c6674b8e2e1d236ca.tar.gz
gentoo-ae6d6ffd8eed52b9ee9c484c6674b8e2e1d236ca.tar.bz2
gentoo-ae6d6ffd8eed52b9ee9c484c6674b8e2e1d236ca.zip
app-forensics/chkrootkit: Version bump (bug 529308, thanks Paolo Pedroni).
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-forensics/chkrootkit/chkrootkit-0.50.ebuild')
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.50.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-forensics/chkrootkit/chkrootkit-0.50.ebuild b/app-forensics/chkrootkit/chkrootkit-0.50.ebuild
new file mode 100644
index 000000000000..d5fc12d93c32
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.50.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz
+ https://dev.gentoo.org/~xmw/${P}-gentoo.diff.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+cron"
+
+RDEPEND="cron? ( virtual/cron )"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-gentoo.diff
+ sed -e 's:/var/adm/:/var/log/:g' \
+ -i chklastlog.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=true sense
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
+
+ if use cron ; then
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+ fi
+}
+
+pkg_postinst() {
+ if use cron ; then
+ elog
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ fi
+
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ elog
+}