summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-05-07 17:05:41 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-05-08 20:40:04 +0200
commita572b97dc10339e4fead42ecc37eb451b1f5ebb3 (patch)
tree9b266ec029a485a92d3a9e1fd54c265f022245e8 /app-forensics/rifiuti
parentapp-forensics/pasco: EAPI8 bump (diff)
downloadgentoo-a572b97dc10339e4fead42ecc37eb451b1f5ebb3.tar.gz
gentoo-a572b97dc10339e4fead42ecc37eb451b1f5ebb3.tar.bz2
gentoo-a572b97dc10339e4fead42ecc37eb451b1f5ebb3.zip
app-forensics/rifiuti: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/30919 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-forensics/rifiuti')
-rw-r--r--app-forensics/rifiuti/rifiuti-20040505_p1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-forensics/rifiuti/rifiuti-20040505_p1-r1.ebuild b/app-forensics/rifiuti/rifiuti-20040505_p1-r1.ebuild
new file mode 100644
index 000000000000..d745c096a672
--- /dev/null
+++ b/app-forensics/rifiuti/rifiuti-20040505_p1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV/_p/_}"
+
+DESCRIPTION="Recycle Bin Analyzer"
+HOMEPAGE="https://sourceforge.net/projects/odessa/"
+SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}/src"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
+}