summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-15 00:53:58 +0100
committerSam James <sam@gentoo.org>2022-01-28 05:14:39 +0000
commitbbe0fd00ae7b550bee5b46cd4f4ca461346f1d97 (patch)
tree0a9f949ad082bed5fe2ebf349e96b9565109014a /app-forensics
parentapp-admin/sudo: add 1.9.9 (diff)
downloadgentoo-bbe0fd00ae7b550bee5b46cd4f4ca461346f1d97.tar.gz
gentoo-bbe0fd00ae7b550bee5b46cd4f4ca461346f1d97.tar.bz2
gentoo-bbe0fd00ae7b550bee5b46cd4f4ca461346f1d97.zip
app-forensics/yara: new ebuild
Bug: https://bugs.gentoo.org/800275 Closes: https://bugs.gentoo.org/576956 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest2
-rw-r--r--app-forensics/yara/metadata.xml29
-rw-r--r--app-forensics/yara/yara-4.1.3.ebuild37
-rw-r--r--app-forensics/yara/yara-4.2.0_rc1.ebuild39
4 files changed, 107 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
new file mode 100644
index 000000000000..20a05f4273f6
--- /dev/null
+++ b/app-forensics/yara/Manifest
@@ -0,0 +1,2 @@
+DIST yara-4.1.3.tar.gz 936462 BLAKE2B abfdd5918abe3641056ccde3eebb754cbd66eff5569978d3b1aad5d925d62fcb96b1f7367d0d014dd165db8634418259667be3b2441f93e0848bfbd905ca32dd SHA512 1bfa1787c62dfd9a87fa8db5e8c2fa68f082ae66b16b5373bdcc6bc66b32016fcaffd4baa7e59a7c1f6d3426c972eca9cc22f70d475067d7557b1014a4ab65fc
+DIST yara-4.2.0_rc1.tar.gz 1283822 BLAKE2B d7bf869e670a0223895aac31df0dbe063d3f0110d1981ae8a42ab26726976790c744b522f13a6963f521310a281fab2b27d6336b23e504a4a9a3d414473ae452 SHA512 03bd09d7c020078946101854e68b7f9ca17c04f7a68624e9e15dc476fe209cc11b010108a0e7aea9746f05aabdbb8d6a6a2ffc54516eb9cb86f170c4259934df
diff --git a/app-forensics/yara/metadata.xml b/app-forensics/yara/metadata.xml
new file mode 100644
index 000000000000..d98a389725d0
--- /dev/null
+++ b/app-forensics/yara/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ YARA is a tool aimed at (but not limited to) helping malware
+ researchers to identify and classify malware samples. With YARA you can
+ create descriptions of malware families (or whatever you want to
+ describe) based on textual or binary patterns.
+ </longdescription>
+ <use>
+ <flag name='cuckoo'>Enable cockoo module</flag>
+ <flag name='dex'>Enable dex module</flag>
+ <flag name='dotnet'>Enable dotnet module</flag>
+ <flag name='macho'>Enable macho module</flag>
+ <flag name='magic'>Enable magic module</flag>
+ <flag name='profiling'>Enable rules profiling</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">VirusTotal/yara</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-forensics/yara/yara-4.1.3.ebuild b/app-forensics/yara/yara-4.1.3.ebuild
new file mode 100644
index 000000000000..ffb30cc26e3a
--- /dev/null
+++ b/app-forensics/yara/yara-4.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="http://virustotal.github.io/yara/"
+SRC_URI="https://github.com/virustotal/yara/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling"
+
+DEPEND="
+ dev-libs/openssl:0=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:0= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex)
+}
diff --git a/app-forensics/yara/yara-4.2.0_rc1.ebuild b/app-forensics/yara/yara-4.2.0_rc1.ebuild
new file mode 100644
index 000000000000..38659ddcaa36
--- /dev/null
+++ b/app-forensics/yara/yara-4.2.0_rc1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="http://virustotal.github.io/yara/"
+SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling"
+
+DEPEND="
+ dev-libs/openssl:0=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:0= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex)
+}