summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-09-28 01:54:59 +0000
committerMike Gilbert <floppym@gentoo.org>2019-09-28 22:56:12 -0400
commit4df9624aac252b98996826438e0615e86686b80e (patch)
tree742efa474de3ac1eff451c8310f370a082e85223 /app-i18n/anthy
parentdev-python/protobuf-python: Version bump (3.9.2). (diff)
downloadgentoo-4df9624aac252b98996826438e0615e86686b80e.tar.gz
gentoo-4df9624aac252b98996826438e0615e86686b80e.tar.bz2
gentoo-4df9624aac252b98996826438e0615e86686b80e.zip
app-i18n/anthy: Use EAPI="7".
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/anthy-9100h-r2.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/app-i18n/anthy/anthy-9100h-r2.ebuild b/app-i18n/anthy/anthy-9100h-r2.ebuild
index 45d7ba0deb52..2ae79f831a70 100644
--- a/app-i18n/anthy/anthy-9100h-r2.ebuild
+++ b/app-i18n/anthy/anthy-9100h-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 2003-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit elisp-common ltprune
+inherit elisp-common
DESCRIPTION="Anthy -- free and secure Japanese input system"
HOMEPAGE="http://anthy.osdn.jp/"
@@ -14,12 +14,16 @@ SLOT="0"
KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="canna-2ch emacs static-libs"
-RDEPEND="canna-2ch? ( app-dicts/canna-2ch )
+BDEPEND="canna-2ch? ( app-dicts/canna-2ch )
emacs? ( virtual/emacs )"
-DEPEND="${RDEPEND}"
+DEPEND=""
+RDEPEND="${BDEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-anthy_context_t.patch )
-DOCS=( AUTHORS ChangeLog DIARY NEWS README )
+PATCHES=(
+ "${FILESDIR}/${PN}-anthy_context_t.patch"
+)
+
+DOCS=(AUTHORS ChangeLog DIARY NEWS README)
SITEFILE="50${PN}-gentoo.el"
@@ -27,27 +31,27 @@ src_prepare() {
default
if use canna-2ch; then
- einfo "Adding nichan.ctd to anthy.dic."
- sed -i "/set_input_encoding eucjp/aread ${EPREFIX}/var/lib/canna/dic/canna/nichan.ctd" mkworddic/dict.args.in
+ einfo "Adding nichan.ctd to anthy.dic"
+ sed -e "/set_input_encoding eucjp/aread ${EPREFIX}/var/lib/canna/dic/canna/nichan.ctd" -i mkworddic/dict.args.in || die
fi
}
src_configure() {
econf \
$(use_enable static-libs static) \
- EMACS=$(usex emacs "${EMACS}")
+ EMACS="$(usex emacs "${EMACS}")"
}
src_install() {
default
- prune_libtool_files
+ find "${D}" -name "*.la" -type f -delete || die
+
+ rm doc/Makefile* || die
+ dodoc -r doc
if use emacs; then
elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
-
- rm -f doc/Makefile*
- dodoc -r doc
}
pkg_postinst() {