summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-23 22:13:20 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-23 22:15:23 +0900
commitf6e84ff2dfd1ffed828390ff78148999cf7eed37 (patch)
tree5f17ab9382999ab054c7a207c51236f7bdab99e4 /app-i18n/canfep/canfep-1.0-r1.ebuild
parentapp-i18n/canfep: fix build with sys-libs/ncurses[tinfo] (diff)
downloadgentoo-f6e84ff2dfd1ffed828390ff78148999cf7eed37.tar.gz
gentoo-f6e84ff2dfd1ffed828390ff78148999cf7eed37.tar.bz2
gentoo-f6e84ff2dfd1ffed828390ff78148999cf7eed37.zip
app-i18n/canfep: add support for Unix98 PTY
Gentoo-Bug: 212709 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/canfep/canfep-1.0-r1.ebuild')
-rw-r--r--app-i18n/canfep/canfep-1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/canfep/canfep-1.0-r1.ebuild b/app-i18n/canfep/canfep-1.0-r1.ebuild
new file mode 100644
index 000000000000..9d542a197161
--- /dev/null
+++ b/app-i18n/canfep/canfep-1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Canna Japanese kana-kanji frontend processor on console"
+HOMEPAGE="http://www.geocities.co.jp/SiliconValley-Bay/7584/canfep/"
+SRC_URI="http://www.geocities.co.jp/SiliconValley-Bay/7584/${PN}/${P}.tar.gz
+ unicode? ( http://hp.vector.co.jp/authors/VA020411/patches/${PN}_utf8.diff )"
+
+LICENSE="canfep"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+RDEPEND="app-i18n/canna
+ sys-libs/ncurses:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-posix-pty.patch )
+
+src_prepare() {
+ use unicode && eapply "${DISTDIR}"/${PN}_utf8.diff
+ sed -i 's/$(CFLAGS)/$(CFLAGS) $(LDFLAGS)/' Makefile
+
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCXX)" \
+ LIBS="-lcanna $(pkg-config --libs ncurses)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc 00{changes,readme}
+}