summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-20 22:30:28 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-20 22:30:28 +0900
commit1fd0f834aad102eb064146cb74ed64c661ff3f49 (patch)
tree106e0a268ca84d892ed69b8afbb1eb4cea391315 /app-i18n/canfep
parentapp-i18n/canfep: respect CXXFLAGS (diff)
downloadgentoo-1fd0f834aad102eb064146cb74ed64c661ff3f49.tar.gz
gentoo-1fd0f834aad102eb064146cb74ed64c661ff3f49.tar.bz2
gentoo-1fd0f834aad102eb064146cb74ed64c661ff3f49.zip
app-i18n/canfep: update to EAPI 7
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/canfep')
-rw-r--r--app-i18n/canfep/canfep-1.0-r1.ebuild6
-rw-r--r--app-i18n/canfep/canfep-1.0.ebuild13
2 files changed, 10 insertions, 9 deletions
diff --git a/app-i18n/canfep/canfep-1.0-r1.ebuild b/app-i18n/canfep/canfep-1.0-r1.ebuild
index 47db7408be3d..df6da3e787de 100644
--- a/app-i18n/canfep/canfep-1.0-r1.ebuild
+++ b/app-i18n/canfep/canfep-1.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit toolchain-funcs
@@ -18,8 +18,8 @@ IUSE="unicode"
RDEPEND="app-i18n/canna
sys-libs/ncurses:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-posix-pty.patch
diff --git a/app-i18n/canfep/canfep-1.0.ebuild b/app-i18n/canfep/canfep-1.0.ebuild
index 318da4e89440..b2f558da0647 100644
--- a/app-i18n/canfep/canfep-1.0.ebuild
+++ b/app-i18n/canfep/canfep-1.0.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit toolchain-funcs
DESCRIPTION="Canna Japanese kana-kanji frontend processor on console"
-HOMEPAGE="http://www.geocities.co.jp/SiliconValley-Bay/7584/canfep/"
-SRC_URI="http://www.geocities.co.jp/SiliconValley-Bay/7584/${PN}/${P}.tar.gz
+#HOMEPAGE="http://www.geocities.co.jp/SiliconValley-Bay/7584/canfep/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz
unicode? ( http://hp.vector.co.jp/authors/VA020411/patches/${PN}_utf8.diff )"
LICENSE="canfep"
@@ -17,8 +18,8 @@ IUSE="unicode"
RDEPEND="app-i18n/canna
sys-libs/ncurses:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
use unicode && eapply "${DISTDIR}"/${PN}_utf8.diff
@@ -31,7 +32,7 @@ src_compile() {
emake \
CC="$(tc-getCXX)" \
CFLAGS="${CXXFLAGS}" \
- LIBS="-lcanna $(pkg-config --libs ncurses)"
+ LIBS="-lcanna $($(tc-getPKG_CONFIG) --libs ncurses)"
}
src_install() {