summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/enca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/enca')
-rw-r--r--app-i18n/enca/Manifest2
-rw-r--r--app-i18n/enca/enca-1.13-r3.ebuild52
-rw-r--r--app-i18n/enca/enca-1.14-r1.ebuild58
-rw-r--r--app-i18n/enca/enca-1.14-r2.ebuild59
-rw-r--r--app-i18n/enca/files/enca-1.14-automake-1.13.patch34
-rw-r--r--app-i18n/enca/files/enca-1.14-gcc4.8-avx-bug.patch15
-rw-r--r--app-i18n/enca/files/enca-remove-dirty-path-hack.patch19
-rw-r--r--app-i18n/enca/metadata.xml17
8 files changed, 256 insertions, 0 deletions
diff --git a/app-i18n/enca/Manifest b/app-i18n/enca/Manifest
new file mode 100644
index 000000000000..29d8660217e7
--- /dev/null
+++ b/app-i18n/enca/Manifest
@@ -0,0 +1,2 @@
+DIST enca-1.13.tar.bz2 532000 SHA256 6c091455d524b3ddae3533fe9bb375092f60ad6fe252e0777c873bd7869c7432 SHA512 7c5cb7b28eea271c4c94135082c1aa3f312bf790aaa4f51c954fd87ed734fae04ec07be99b20e7dfa3a668349c17d97f1eeea1ee553f9b841e74bfafc5a5906a WHIRLPOOL 0080ce92c22c5ad8b34eea767133602d73e3ebcbcb5084794e5e5da37edceab1bba9785f3884aa5c84749be89116eecf7bc59faa0ebb7118e97411f97e97e4a8
+DIST enca-1.14.tar.bz2 560982 SHA256 7f33e3953fbbdac8ed144b31bbab1bb3bf181150db6ba4cd812fd958ce5f4b58 SHA512 9d0582cc8187f3e868339c3e13ca2c654359b240dd564b64a31615aeffb0ec7ae025659576cc72f6cab73b0bfa22286060f665f2c952f8dfe702cf97a39d2245 WHIRLPOOL 921038e3c6a612b38820d7314a7afe83c231e48396cd801dcbeb3f64afe157b0b5009ada00ae59f35ee4a882c4a40f46ac3346139c99da00611b073b561cfbee
diff --git a/app-i18n/enca/enca-1.13-r3.ebuild b/app-i18n/enca/enca-1.13-r3.ebuild
new file mode 100644
index 000000000000..ae119dde3a8e
--- /dev/null
+++ b/app-i18n/enca/enca-1.13-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+AUTOTOOLS_AUTORECONF=2.52
+inherit eutils toolchain-funcs autotools-utils
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +recode"
+
+DEPEND="recode? ( >=app-text/recode-3.6_p15 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-remove-dirty-path-hack.patch
+ # fix crosscompilation, bug #424473
+ if tc-is-cross-compiler; then
+ sed -e "s#./make_hash#./native_make_hash#" -i tools/Makefile.am || die
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-external
+ --disable-static
+ $(use_with recode librecode "${EPREFIX}"/usr)
+ $(use_enable doc gtk-doc)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ pushd "${AUTOTOOLS_BUILD_DIR}"/tools > /dev/null
+ $(tc-getBUILD_CC) -o native_make_hash "${S}"/tools/make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ autotools-utils_src_compile
+}
+
+src_install() {
+ autotools-utils_src_install
+}
diff --git a/app-i18n/enca/enca-1.14-r1.ebuild b/app-i18n/enca/enca-1.14-r1.ebuild
new file mode 100644
index 000000000000..b94dd24e52fa
--- /dev/null
+++ b/app-i18n/enca/enca-1.14-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+AUTOTOOLS_AUTORECONF=2.52
+
+inherit eutils toolchain-funcs autotools-multilib
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +recode"
+
+DEPEND="recode? ( >=app-text/recode-3.6_p15 )
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-remove-dirty-path-hack.patch
+ epatch "${FILESDIR}"/${P}-automake-1.13.patch
+ rm missing # too old, automake will update it
+ # fix crosscompilation, bug #424473
+ if tc-is-cross-compiler; then
+ sed -e "s#./make_hash#./native_make_hash#" -i tools/Makefile.am || die
+ fi
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-external
+ --disable-static
+ $(use_with recode librecode "${EPREFIX}"/usr)
+ $(use_enable doc gtk-doc)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_compile() {
+ if tc-is-cross-compiler; then
+ pushd "${BUILD_DIR}"/tools > /dev/null
+ $(tc-getBUILD_CC) -o native_make_hash "${S}"/tools/make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ # It will fail if we run these twice...
+ if ! multilib_is_native_abi ; then
+ sed -i -e 's/ src / /' Makefile || die
+ sed -i -e '/SUBDIRS/s/ test//' Makefile || die
+ sed -i -e 's/install-data-hook:/install-data-hook:\n\ndisabled:/' Makefile || die
+ fi
+ autotools-utils_src_compile
+}
diff --git a/app-i18n/enca/enca-1.14-r2.ebuild b/app-i18n/enca/enca-1.14-r2.ebuild
new file mode 100644
index 000000000000..d8de93abdfde
--- /dev/null
+++ b/app-i18n/enca/enca-1.14-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=2.52
+
+inherit eutils toolchain-funcs autotools-multilib
+
+DESCRIPTION="ENCA detects the character coding of a file and converts it if desired"
+HOMEPAGE="http://gitorious.org/enca"
+SRC_URI="http://dl.cihar.com/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ~ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc +recode"
+
+RDEPEND="recode? ( >=app-text/recode-3.6_p15 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-remove-dirty-path-hack.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch \
+ "${FILESDIR}"/${P}-gcc4.8-avx-bug.patch
+ rm missing # too old, automake will update it
+ # fix crosscompilation, bug #424473
+ if tc-is-cross-compiler; then
+ sed -e "s#./make_hash#./native_make_hash#" -i tools/Makefile.am || die
+ fi
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-external
+ --disable-static
+ $(use_with recode librecode "${EPREFIX}"/usr)
+ $(use_enable doc gtk-doc)
+ )
+ autotools-multilib_src_configure
+}
+
+multilib_src_compile() {
+ if tc-is-cross-compiler; then
+ pushd "${BUILD_DIR}"/tools > /dev/null
+ $(tc-getBUILD_CC) -o native_make_hash "${S}"/tools/make_hash.c || die "native make_hash failed"
+ popd > /dev/null
+ fi
+ # It will fail if we run these twice...
+ if ! multilib_is_native_abi ; then
+ sed -i -e 's/ src / /'\
+ -e '/SUBDIRS/s/ test//' Makefile\
+ -e 's/install-data-hook:/install-data-hook:\n\ndisabled:/' Makefile || die
+ fi
+ autotools-utils_src_compile
+}
diff --git a/app-i18n/enca/files/enca-1.14-automake-1.13.patch b/app-i18n/enca/files/enca-1.14-automake-1.13.patch
new file mode 100644
index 000000000000..653295793fa1
--- /dev/null
+++ b/app-i18n/enca/files/enca-1.14-automake-1.13.patch
@@ -0,0 +1,34 @@
+diff --git a/configure.ac b/configure.ac
+index 956763d..6a624ab 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -24,7 +24,7 @@ AC_CONFIG_FILES( \
+ test/Makefile \
+ tools/Makefile)
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AM_INIT_AUTOMAKE([1.8 gnits check-news dist-bzip2])
+ AM_ACLOCAL_INCLUDE(m4)
+ AM_MAINTAINER_MODE
+@@ -40,7 +40,7 @@ AC_GNU_SOURCE
+ AC_AIX
+ AC_ISC_POSIX
+ AC_PROG_LIBTOOL
+-AM_PROG_CC_STDC
++AC_PROG_CC
+ AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+diff --git a/m4/typevar.m4 b/m4/typevar.m4
+index ce9578d..66077eb 100644
+--- a/m4/typevar.m4
++++ b/m4/typevar.m4
+@@ -6,7 +6,6 @@
+ ## defined in errno.h
+ AC_DEFUN([ye_CHECK_VAR_PROGRAM_INVOCATION_SHORT_NAME],
+ [AC_REQUIRE([AC_PROG_CC])dnl
+-AC_REQUIRE([AM_PROG_CC_STDC])dnl
+ dnl
+
+ dnl Check for program_invocation_short_name (present on GNU systems only?)
diff --git a/app-i18n/enca/files/enca-1.14-gcc4.8-avx-bug.patch b/app-i18n/enca/files/enca-1.14-gcc4.8-avx-bug.patch
new file mode 100644
index 000000000000..3753c73acc98
--- /dev/null
+++ b/app-i18n/enca/files/enca-1.14-gcc4.8-avx-bug.patch
@@ -0,0 +1,15 @@
+Avoid gcc-4.8.4 bug when built with -O3 -march=core-avx2
+https://bugs.gentoo.org/501386
+diff --git a/lib/multibyte.c b/lib/multibyte.c
+index d0d0680..d511f88 100644
+--- a/lib/multibyte.c
++++ b/lib/multibyte.c
+@@ -520,7 +520,7 @@ looks_like_ucs2(EncaAnalyserState *analyser)
+ static int
+ looks_like_ucs4(EncaAnalyserState *analyser)
+ {
+- static const EncaSurface PERMS[] = {
++ /*static*/ const EncaSurface PERMS[] = {
+ ENCA_SURFACE_PERM_4321,
+ ENCA_SURFACE_PERM_21
+ };
diff --git a/app-i18n/enca/files/enca-remove-dirty-path-hack.patch b/app-i18n/enca/files/enca-remove-dirty-path-hack.patch
new file mode 100644
index 000000000000..b96667cd288f
--- /dev/null
+++ b/app-i18n/enca/files/enca-remove-dirty-path-hack.patch
@@ -0,0 +1,19 @@
+diff -Naur enca-1.13.orig//configure.ac enca-1.13/configure.ac
+--- enca-1.13.orig//configure.ac 2010-02-09 05:23:03.000000000 -0500
++++ enca-1.13/configure.ac 2012-06-29 18:04:51.000000000 -0400
+@@ -97,15 +97,6 @@
+ dnl Check for good random number sources
+ AC_CHECK_FILES(/dev/random /dev/urandom /dev/srandom /dev/arandom)
+
+-dnl Dirty path hack. Helps some people with badly set up search paths.
+-if test "$prefix" = "NONE"; then
+- LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
+- CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
+-else
+- LDFLAGS="$LDFLAGS -L$prefix/lib"
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"
+-fi
+-
+ dnl Checks for libraries.
+ ye_CHECK_LIBM
+
diff --git a/app-i18n/enca/metadata.xml b/app-i18n/enca/metadata.xml
new file mode 100644
index 000000000000..d10f1bc6bc1c
--- /dev/null
+++ b/app-i18n/enca/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>stasrtf@gmail.com</email>
+ <description>Proxy maintainer</description>
+ <name>Stas</name>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitorious">enca</remote-id>
+ </upstream>
+</pkgmetadata>