summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/fbterm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/fbterm')
-rw-r--r--app-i18n/fbterm/Manifest1
-rw-r--r--app-i18n/fbterm/fbterm-1.7-r1.ebuild57
-rw-r--r--app-i18n/fbterm/metadata.xml5
3 files changed, 63 insertions, 0 deletions
diff --git a/app-i18n/fbterm/Manifest b/app-i18n/fbterm/Manifest
new file mode 100644
index 000000000000..2dcaedde78b5
--- /dev/null
+++ b/app-i18n/fbterm/Manifest
@@ -0,0 +1 @@
+DIST fbterm-1.7.0.tar.gz 188642 SHA256 720f600817217257aa4c822e67814495dcb6c8d6326cdde5fe3ba1e457d9915d SHA512 ba78b5118b5e4c65046f7f91ce88cb4f828e2debb34358df8518e1907a8d601a2be4dfcf144e84494dc30e4828d333574debe8dd3ffb59e2169c3e48ba1f6a10 WHIRLPOOL 7e01fff188974218a71c4083a4185d52a188431bbd1d282b8d9ca79189854ba5dc942476c83f543fbbe449ddc22f223166be2f6617b04c0d0e0acd240b762c11
diff --git a/app-i18n/fbterm/fbterm-1.7-r1.ebuild b/app-i18n/fbterm/fbterm-1.7-r1.ebuild
new file mode 100644
index 000000000000..d575cfa1f755
--- /dev/null
+++ b/app-i18n/fbterm/fbterm-1.7-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools-utils
+
+DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
+HOMEPAGE="http://fbterm.googlecode.com/"
+SRC_URI="http://fbterm.googlecode.com/files/${P}.0.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="caps gpm video_cards_vesa"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ gpm? ( sys-libs/gpm )
+ video_cards_vesa? ( dev-libs/libx86 )
+ media-libs/fontconfig
+ media-libs/freetype:2"
+DEPEND="${RDEPEND}
+ sys-libs/ncurses
+ virtual/pkgconfig"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gpm)
+ $(use_enable video_cards_vesa vesa)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ $(type -P tic) -o "${ED}/usr/share/terminfo/" \
+ "${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
+ if use caps; then
+ setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
+ else
+ fperms u+s /usr/bin/fbterm
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo " ${PN} won't work with vga16fb. You have to use other native"
+ einfo " framebuffer drivers or vesa driver."
+ einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
+ einfo " To use ${PN}, ensure you are in video group."
+ einfo " To input CJK merge app-i18n/fbterm-ucimf"
+ einfo
+}
diff --git a/app-i18n/fbterm/metadata.xml b/app-i18n/fbterm/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/app-i18n/fbterm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>