summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-19 22:38:46 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 13:24:39 -0400
commit4b11df06aac7ecbb6fe6bcfc53a9174c08d66f97 (patch)
treee6ea58afbb4531c7c2719f42e7275d1347eec955 /app-i18n/fcitx-anthy
parentapp-i18n/sunpinyin: Set subslot based on soname of libsunpinyin.so. (diff)
downloadgentoo-4b11df06aac7ecbb6fe6bcfc53a9174c08d66f97.tar.gz
gentoo-4b11df06aac7ecbb6fe6bcfc53a9174c08d66f97.tar.bz2
gentoo-4b11df06aac7ecbb6fe6bcfc53a9174c08d66f97.zip
app-i18n/fcitx-anthy: Version bump (0.2.3).
Diffstat (limited to 'app-i18n/fcitx-anthy')
-rw-r--r--app-i18n/fcitx-anthy/Manifest1
-rw-r--r--app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-i18n/fcitx-anthy/Manifest b/app-i18n/fcitx-anthy/Manifest
index 8b9834bb2528..f32c172fee96 100644
--- a/app-i18n/fcitx-anthy/Manifest
+++ b/app-i18n/fcitx-anthy/Manifest
@@ -1,3 +1,4 @@
DIST fcitx-anthy-0.1.1.tar.xz 68604 SHA256 c508068c7c9a56c26ea44b8e6ddb90a2ea75860031f89e171dcda8ec4cd08955 SHA512 e2c4bb20f0b0a370e5f28bff14312c2c14210695418438ebe697b94570fe502be8c96dc8fbf813fd3aa6e352283a7d31808a1f12266d4a8050646a8ae86de9d9 WHIRLPOOL 48f674ef23d62f2dc1286712cbb252d709d9e3890921d1f9296ff89f85c5ae211daa887841fc01f267fe44764275e8b6de4aef859d9f1456cb24f00023b262ce
DIST fcitx-anthy-0.2.1.tar.xz 72196 SHA256 fd208474666f09f1c189c10c2c0fa9cfda33948b704410e02878fdd92174d78d SHA512 18599251d6ebda96a23f81f63d91e9a9d469d2ea534975c2f4ddbc80584d70646ac6d157d0571f9d48565c0cfd1bb111e2907cae2c00b750014b9f39a7bcf961 WHIRLPOOL 99632911a7831ce24c7535b0e0a249cbbc48b24ec44682f6a09e3dc0a61d7eb74363642098158cc409c3390fb141d03591f1e1b1b3683164d4d6002fe9c92769
DIST fcitx-anthy-0.2.2.tar.xz 72360 SHA256 c8dd54fee3ada834d6ed0df561a95210256ea2a17fa5e00d9ae09892bafbd92b SHA512 a4b1eeba813481cc40617e70bd5ee97d1921dc92bab15cf0bdc059d689c239e46caf9e8aba3403ff6374acfbdea565261a948444fe40fa18d5513797eccbd28d WHIRLPOOL 7427384e8e12d7e35027a4a149cc758828fb9664204490d35f7b43ad083cc8545c4b52164af716065bccdd4a347f047e34c80cac32699641798fd2e21dccc8ea
+DIST fcitx-anthy-0.2.3.tar.xz 78020 SHA256 ed9b4956356ca68e5f7bdd46492873ebebc921a6cf713d7fc62e5680393f5d06 SHA512 2769871059053fb370ba84af7cdf0c461d64724a240d58a5a8889cfd9bfb5d145998f79ed2d06a1ae1ab907f9db04fc122bfaf6957ef572fc833e400ffefc642 WHIRLPOOL 4550f529d98b31abf7e632998fdd5d082045ce2daff251a860f7feaa966fba2955d7fdfbdf0be977f81c64cdd0473f082e8356569d70f3c29943846e9ea92570
diff --git a/app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild b/app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild
new file mode 100644
index 000000000000..b9f2d9c0e8dd
--- /dev/null
+++ b/app-i18n/fcitx-anthy/fcitx-anthy-0.2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-anthy"
+fi
+
+DESCRIPTION="Japanese Anthy input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-anthy"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[X,xml]
+ app-i18n/anthy:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}