summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-26 22:46:27 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-27 15:56:58 -0400
commit1b4cadf88b5643baea6adef2d9769f0ed138d145 (patch)
tree4b5c5d2bef4b7523d8a7cb6e0f97185792b820fb /app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild
parentapp-i18n/fcitx: Use ${Fcitx_major_version}.9999 version scheme for live ebuild. (diff)
downloadgentoo-1b4cadf88b5643baea6adef2d9769f0ed138d145.tar.gz
gentoo-1b4cadf88b5643baea6adef2d9769f0ed138d145.tar.bz2
gentoo-1b4cadf88b5643baea6adef2d9769f0ed138d145.zip
app-i18n/fcitx-chewing: Use ${Fcitx_major_version}.9999 version scheme for live ebuild.
Diffstat (limited to 'app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild')
-rw-r--r--app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild b/app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild
new file mode 100644
index 000000000000..81658f7c3209
--- /dev/null
+++ b/app-i18n/fcitx-chewing/fcitx-chewing-4.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-chewing"
+fi
+
+DESCRIPTION="Chinese Chewing input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-chewing"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ >=app-i18n/libchewing-0.5.0:=
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}