summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-13 00:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-16 14:51:13 -0500
commit6f46ae625bdaa20c3adc2e429c1b35a3aa680132 (patch)
treee5c40c524296f3a28dda80fd4bf75a2f33c2a994 /app-i18n/fcitx-qt5
parentwww-client/firefox: guard __NR_fork with ifdef (diff)
downloadgentoo-6f46ae625bdaa20c3adc2e429c1b35a3aa680132.tar.gz
gentoo-6f46ae625bdaa20c3adc2e429c1b35a3aa680132.tar.bz2
gentoo-6f46ae625bdaa20c3adc2e429c1b35a3aa680132.zip
app-i18n/fcitx-qt5: Version bump (1.2.4).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx-qt5')
-rw-r--r--app-i18n/fcitx-qt5/Manifest1
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-1.2.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/Manifest b/app-i18n/fcitx-qt5/Manifest
index 5959966f61d1..bd24cbd21bef 100644
--- a/app-i18n/fcitx-qt5/Manifest
+++ b/app-i18n/fcitx-qt5/Manifest
@@ -1 +1,2 @@
DIST fcitx-qt5-1.2.3.tar.xz 134124 BLAKE2B 0c17f9c3b9d9878fe228881c7287375d3b73a8c27f806590747e56b8644a86300e243d62efcb6589d197edd352e2a79d49be704718ff53381e2fb5e2a5a2b1af SHA512 e3e9a76419caca4eeebf3c149a72ee939a25f463d03dd8461caf44cace310278b08e83d460112f240cd54ed05dba3c5e9732198f0c3d0b9d81c3a444c33ab8d3
+DIST fcitx-qt5-1.2.4.tar.xz 107620 BLAKE2B 3577555192d2eda9e48fbd31149100f0d21fd1b0b7d162d14cef89818f86d5e32e2bb835f4f47acf150cfd0b0fc506031454e4ffe1315424314fc7512d391f8f SHA512 c9ceaaedeb26ac4c7fa1e0bf34096725afc14642b795d9c624f4fc7fbf56c04acad12d8d3ffb60c164281b6373554c0524e56209a2d1d123fbf348d15dcc282a
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-1.2.4.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.4.ebuild
new file mode 100644
index 000000000000..610eb112d602
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2014-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-qt5"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5"
+
+DOCS=()