summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2019-03-02 22:01:29 +0900
committerAkinori Hattori <hattya@gentoo.org>2019-03-02 22:01:29 +0900
commitc1f8aceba92191a7f6326040f06405b60b66e7b3 (patch)
treecda0c47715d8ba69c4e4449e5a7db5510aa422b5 /app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild
parentwww-servers/h2o: fix build with >=dev-libs/libressl-2.7 (diff)
downloadgentoo-c1f8aceba92191a7f6326040f06405b60b66e7b3.tar.gz
gentoo-c1f8aceba92191a7f6326040f06405b60b66e7b3.tar.bz2
gentoo-c1f8aceba92191a7f6326040f06405b60b66e7b3.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild')
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild
new file mode 100644
index 000000000000..2b94c3fcc8c1
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"