summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-10-11 16:25:17 +0800
committerYixun Lan <dlan@gentoo.org>2016-10-11 16:27:27 +0800
commit8dc9318d3809c9418b3faff3dd09ef3daf962b5d (patch)
tree5402f3195e432c4634f06f296ebf8d9a96b0668f /app-i18n/ibus-unikey
parentnet-p2p/go-ethereum: Version bump (diff)
downloadgentoo-8dc9318d3809c9418b3faff3dd09ef3daf962b5d.tar.gz
gentoo-8dc9318d3809c9418b3faff3dd09ef3daf962b5d.tar.bz2
gentoo-8dc9318d3809c9418b3faff3dd09ef3daf962b5d.zip
app-i18n/ibus-unikey: fix gcc-6 build err
Gentoo-Bug: 593992 Package-Manager: portage-2.3.1
Diffstat (limited to 'app-i18n/ibus-unikey')
-rw-r--r--app-i18n/ibus-unikey/Manifest1
-rw-r--r--app-i18n/ibus-unikey/ibus-unikey-0.6.1-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-i18n/ibus-unikey/Manifest b/app-i18n/ibus-unikey/Manifest
index 72fb913c076c..32af707f45ff 100644
--- a/app-i18n/ibus-unikey/Manifest
+++ b/app-i18n/ibus-unikey/Manifest
@@ -1 +1,2 @@
+DIST ibus-unikey-0.6.1-gcc6.patch 31686 SHA256 928b12d470994072bb4b08472b365b340a24e07e83c2020905de3ecaf61a1dee SHA512 9e1b172a904076ba817c7bab80cbbf7d736c078d3ea285cb946be23552ff0f571ca8e0187cac4e5bfecc2b0032512d6f09af4435056d6b653a3648d07356d9b2 WHIRLPOOL 6e4d232dddf7520da365692180199167a0f9c89f597d984abe0e698b815af174764477df78e220fe8bc5e364be40fd7e6912b69f0d6446fda0244f1a6271e3b8
DIST ibus-unikey-0.6.1.tar.gz 516250 SHA256 989bbea706d2d8d7b86630b1f2b4f63d8ed5167a1cc2b8fafd7f2198ec78d734 SHA512 f8d519802d9b304cdaebfcee3f9fef5f17756cde48aa48b9dd357d714e2eaaba0df8f91218b658fdd1d85343804e054b7987caff2734913b29dc76263c30d4e6 WHIRLPOOL 4a14d0145477527b100272801f2ac8e90178c8d6d7ae743619d6babcf1da069bc550a3eac473c8ac9b60e0b5eeaf1ea780a97d1e3ebd81a0b557e51f20615c4c
diff --git a/app-i18n/ibus-unikey/ibus-unikey-0.6.1-r1.ebuild b/app-i18n/ibus-unikey/ibus-unikey-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..df2b22c62b8d
--- /dev/null
+++ b/app-i18n/ibus-unikey/ibus-unikey-0.6.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="Vietnamese Input Method Engine for IBUS using Unikey IME"
+HOMEPAGE="https://code.google.com/p/ibus-unikey/"
+SRC_URI="https://ibus-unikey.googlecode.com/files/${P}.tar.gz
+ https://dev.gentoo.org/~dlan/distfiles/${P}-gcc6.patch"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk3"
+
+RDEPEND="gtk3? ( >app-i18n/ibus-1.4.0[gtk3]
+ x11-libs/gtk+:3 )
+ !gtk3? ( >=app-i18n/ibus-1.4.0
+ >=x11-libs/gtk+-2.12:2 )
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ >=sys-devel/gettext-0.17"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-gcc6.patch
+}
+
+src_configure() {
+ use gtk3 && myconf="--with-gtk-version=3" || myconf=""
+ econf ${myconf}
+}