summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-17 00:14:03 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-17 00:14:03 +0900
commit7b4a29865267aba3cf3358e016e0777a6d5fef7d (patch)
treeeed8b28122d5f44818b9a72802dfcac9c8107d3f /app-i18n/libchewing/libchewing-0.5.1.ebuild
parentapp-i18n/libchewing: fix src_test (diff)
downloadgentoo-7b4a29865267aba3cf3358e016e0777a6d5fef7d.tar.gz
gentoo-7b4a29865267aba3cf3358e016e0777a6d5fef7d.tar.bz2
gentoo-7b4a29865267aba3cf3358e016e0777a6d5fef7d.zip
app-i18n/libchewing: new upstream release
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/libchewing/libchewing-0.5.1.ebuild')
-rw-r--r--app-i18n/libchewing/libchewing-0.5.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/libchewing/libchewing-0.5.1.ebuild b/app-i18n/libchewing/libchewing-0.5.1.ebuild
new file mode 100644
index 000000000000..5f89bccd1733
--- /dev/null
+++ b/app-i18n/libchewing/libchewing-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune
+
+DESCRIPTION="Library for Chinese Phonetic input method"
+HOMEPAGE="http://chewing.csie.net/"
+SRC_URI="https://github.com/${PN/lib}/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs test"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/check
+ sys-libs/ncurses[unicode]
+ )"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-sqlite3
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}