summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-17 17:37:37 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-17 17:38:20 -0400
commit7f7cdada5c919e34bd0f159592ea3f7e1d07a69a (patch)
tree92ca2687b3862eef5bd6d38e3c8b4a19032267b8 /app-i18n/man-pages-de/man-pages-de-2.5.ebuild
parentwww-apps/nextcloud: 14.0.3, 13.0.7, 12.0.12 bumps (diff)
downloadgentoo-7f7cdada5c919e34bd0f159592ea3f7e1d07a69a.tar.gz
gentoo-7f7cdada5c919e34bd0f159592ea3f7e1d07a69a.tar.bz2
gentoo-7f7cdada5c919e34bd0f159592ea3f7e1d07a69a.zip
app-i18n/man-pages-de: bump to 2.5
Reported-By: Markus Oehme Closes: https://bugs.gentoo.org/654858 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-i18n/man-pages-de/man-pages-de-2.5.ebuild')
-rw-r--r--app-i18n/man-pages-de/man-pages-de-2.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/man-pages-de/man-pages-de-2.5.ebuild b/app-i18n/man-pages-de/man-pages-de-2.5.ebuild
new file mode 100644
index 000000000000..d8f50681b5ef
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN/-/}-v${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="https://salsa.debian.org/manpages-de-team/manpages-de"
+SRC_URI="https://salsa.debian.org/manpages-de-team/manpages-de/-/archive/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="app-text/po4a"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ default
+
+ # sys-apps/shadow has it's own translated man-page for this
+ rm "${S}/upstream/primary/man1/groups.1" || die
+ rm "${S}/po/primary/man1/groups.1.po" || die
+}
+
+src_prepare() {
+ default
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+ PORTAGE_COMPRESS_LOCAL="#"
+ fi
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+ sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+ po/Makefile.in || die
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES.md README.md
+}