summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-09 10:06:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-09 10:09:58 +0200
commit7c8040255f8b39dd763938fa7f5c2bf33bba5364 (patch)
treee7f82fb8f7fe499b6bb9a9d24df0260f698b155c /app-i18n/man-pages-de
parentnet-misc/tor: version bump to 0.2.9.1_alpha (diff)
downloadgentoo-7c8040255f8b39dd763938fa7f5c2bf33bba5364.tar.gz
gentoo-7c8040255f8b39dd763938fa7f5c2bf33bba5364.tar.bz2
gentoo-7c8040255f8b39dd763938fa7f5c2bf33bba5364.zip
app-i18n/man-pages-de: Bump to version 1.14 (bug #590858).
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-i18n/man-pages-de')
-rw-r--r--app-i18n/man-pages-de/Manifest1
-rw-r--r--app-i18n/man-pages-de/man-pages-de-1.14.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-i18n/man-pages-de/Manifest b/app-i18n/man-pages-de/Manifest
index b574a7edd2a1..c07a00aac355 100644
--- a/app-i18n/man-pages-de/Manifest
+++ b/app-i18n/man-pages-de/Manifest
@@ -1,2 +1,3 @@
DIST manpages-de-1.12.tar.xz 1475896 SHA256 ad7e49205fdc438eccf69823f406eb5ea6d5fb562a89b6ccac24a07f92b0bb77 SHA512 dd2873e4f72ec1d3c634b95c6b8a843a907ebdf9c79efb74ae333a1ac32003d403dd4e4fa346a6902a9397c06b4dc643a8bed73c90cab522d146f31253249c1d WHIRLPOOL cc3957ec918fa6fc86bda6148c5c7071dd7fe3a8a7cd33413e636a38f1c5d007e24333f680f843ed14d95f8620998d3097ede5aefaca5592cc28d8d591ffb817
DIST manpages-de-1.13.tar.xz 1487316 SHA256 d8e278055008ffb11e662fed10aa5b9200caa963ebac41697f38d4f2e9641fff SHA512 ba7c95c83550318c5453bc45c78d162aa83c5d95802c539d62b4e85cc432d20dcace5ab8482f496eca6c50728497a71888f1274df64344a99d6370a256c9e20c WHIRLPOOL fffc6fcb65662dd740253e45bcee00d0539332503392f198db0abd086feaeef5b43f48e303e060fd9d2669ed20d611ac5ba34618884e5549f2f82854af008d5e
+DIST manpages-de-1.14.tar.xz 1508600 SHA256 b5b8baecb7a7fb414e825a90377e96546f7b6c503a800ab6fe19f9ed60db1047 SHA512 096f883f430311fb5be56905d30d6c79e516842cb1d7338f24b5fffaf89d287f235ddc0839040bea3318b96cd5c291317a103992ed4a1735065eac74f4fba6dc WHIRLPOOL a542ac7f844144dfbf0a69fee6e74725dd9ed56a58d36215b2ab9aa4587d950d8eab990c6c6b05a66f5bab36fa5f675988d79555eef14f804e174977641034b5
diff --git a/app-i18n/man-pages-de/man-pages-de-1.14.ebuild b/app-i18n/man-pages-de/man-pages-de-1.14.ebuild
new file mode 100644
index 000000000000..8eb53fac8067
--- /dev/null
+++ b/app-i18n/man-pages-de/man-pages-de-1.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN/-/}-${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="http://alioth.debian.org/projects/manpages-de/"
+SRC_URI="http://manpages-de.alioth.debian.org/downloads/${MY_P}.tar.xz"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="app-text/po4a"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3-bzip2.patch"
+)
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # Use the same compression as every other manpage
+ local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+ if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+ PORTAGE_COMPRESS_LOCAL="#"
+ fi
+ if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+ case ${PORTAGE_COMPRESS_LOCAL} in
+ bzip2|gzip) local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+ ;;
+ esac
+ fi
+ sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+ po/man{1,2,3,4,5,6,7,8}/Makefile.in po/common.mk || die
+ eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake mandir="${ED}"/usr/share/man install
+ dodoc CHANGES README
+}