summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/multiskkserv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/multiskkserv/files')
-rw-r--r--app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch45
-rw-r--r--app-i18n/multiskkserv/files/multiskkserv.conf15
-rw-r--r--app-i18n/multiskkserv/files/multiskkserv.initd31
3 files changed, 91 insertions, 0 deletions
diff --git a/app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch b/app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch
new file mode 100644
index 000000000000..938043ca46b3
--- /dev/null
+++ b/app-i18n/multiskkserv/files/multiskkserv-20100128-cdb.patch
@@ -0,0 +1,45 @@
+diff --git a/configure.in b/configure.in
+index 648f742..2ac4e92 100644
+--- a/configure.in
++++ b/configure.in
+@@ -108,22 +108,24 @@ if test "$with_cdb" = "no"; then
+ else
+ if test "$with_cdb" = "yes"; then
+ for i in /usr/local /usr; do
+- if test -d "$i/include" -a -f "$i/include/cdb.h"; then
+- CDB_DIR="$i"
+- CDB_INCLUDES="-I$i/include"
+- available_cdb="yes"
+- for j in cdb.a buffer.a unix.a byte.a alloc.a; do
+- if test -f "$i/lib/$j"; then
+- LIBADD_CDB="$LIBADD_CDB $i/lib/$j"
+- else
+- available_cdb="no"
+- break
+- fi
+- done
+- if test "$available_cdb" = "yes"; then
+- break
+- fi
+- fi
++ for inc in include include/cdb; do
++ if test -d "$i/$inc" -a -f "$i/$inc/cdb.h"; then
++ CDB_DIR="$i"
++ CDB_INCLUDES="-I$i/$inc"
++ available_cdb="yes"
++ for j in cdb.a buffer.a unix.a byte.a alloc.a; do
++ if test -f "$i/lib/$j"; then
++ LIBADD_CDB="$LIBADD_CDB $i/lib/$j"
++ else
++ available_cdb="no"
++ break
++ fi
++ done
++ if test "$available_cdb" = "yes"; then
++ break
++ fi
++ fi
++ done
+ done
+ else
+ if test -d "$with_cdb" -a -f "$with_cdb/cdb.h"; then
diff --git a/app-i18n/multiskkserv/files/multiskkserv.conf b/app-i18n/multiskkserv/files/multiskkserv.conf
new file mode 100644
index 000000000000..e2e95fd8e501
--- /dev/null
+++ b/app-i18n/multiskkserv/files/multiskkserv.conf
@@ -0,0 +1,15 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Config file for /etc/init.d/multiskkserv
+
+# define which SKK-JISYO to use (you may define multiple files)
+#
+# Example:
+#
+# SKKJISYO_CDB="SKK-JISYO.L.cdb SKK-JISYO.JIS2.cdb SKK-JISYO.jinmei.cdb"
+#
+
+SKKJISYO_CDB="SKK-JISYO.L.cdb"
+
diff --git a/app-i18n/multiskkserv/files/multiskkserv.initd b/app-i18n/multiskkserv/files/multiskkserv.initd
new file mode 100644
index 000000000000..22a6d5fb43e3
--- /dev/null
+++ b/app-i18n/multiskkserv/files/multiskkserv.initd
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ if [ -e /var/run/multiskkserv.pid ] ; then
+ eerror "Anothor pid file is detected."
+ eerror "If you are sure any multiskkserv is not running,"
+ eerror "please rm /var/run/multiskkserv manually."
+ fi
+
+ ebegin "Starting multiskkserv"
+ start-stop-daemon --start --quiet --background \
+ --make-pidfile --pidfile /var/run/multiskkserv.pid \
+ /usr/sbin/multiskkserv -- \
+ -r /usr/share/skk ${SKKJISYO_CDB}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping multiskkserv"
+ start-stop-daemon --stop --quiet -R 5 \
+ --pidfile /var/run/multiskkserv.pid \
+ --exec /usr/sbin/multiskkserv
+ eend $?
+}