summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-01 22:25:32 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-01 22:25:32 +0900
commitd3e2a8d5314f00b8e8c8d838ef83d73d58e0b288 (patch)
tree7979232b266fa3346ce948d9a7239bd3389e1591 /app-i18n/multiskkserv/multiskkserv-20100128.ebuild
parentapp-i18n/skkfep: fix build with >=sys-libs/glibc-2.24 (diff)
downloadgentoo-d3e2a8d5314f00b8e8c8d838ef83d73d58e0b288.tar.gz
gentoo-d3e2a8d5314f00b8e8c8d838ef83d73d58e0b288.tar.bz2
gentoo-d3e2a8d5314f00b8e8c8d838ef83d73d58e0b288.zip
app-i18n/multiskkserv: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/multiskkserv/multiskkserv-20100128.ebuild')
-rw-r--r--app-i18n/multiskkserv/multiskkserv-20100128.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/app-i18n/multiskkserv/multiskkserv-20100128.ebuild b/app-i18n/multiskkserv/multiskkserv-20100128.ebuild
index 0f34d617864b..b6ec66dc57b3 100644
--- a/app-i18n/multiskkserv/multiskkserv-20100128.ebuild
+++ b/app-i18n/multiskkserv/multiskkserv-20100128.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
-inherit autotools eutils
+inherit autotools
DESCRIPTION="SKK server that handles multiple dictionaries"
HOMEPAGE="http://www3.big.or.jp/~sian/linux/products/"
@@ -14,16 +14,15 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="test"
-DEPEND="app-arch/xz-utils
- dev-db/cdb
+DEPEND="dev-db/cdb
test? ( app-i18n/nkf )"
-RDEPEND="|| (
- >=app-i18n/skk-jisyo-200705[cdb]
- app-i18n/skk-jisyo-cdb
- )"
+RDEPEND="app-i18n/skk-jisyo[cdb]"
+
+PATCHES=( "${FILESDIR}"/${P}-cdb.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-cdb.patch
+ default
+ mv configure.{in,ac}
eautoreconf
}
@@ -34,12 +33,6 @@ src_configure() {
src_install() {
default
- newconfd "${FILESDIR}"/multiskkserv.conf multiskkserv
- newinitd "${FILESDIR}"/multiskkserv.initd multiskkserv
-}
-
-pkg_postinst() {
- elog "By default, multiskkserv will look up only SKK-JISYO.L.cdb."
- elog "If you want to use more dictionaries,"
- elog "edit /etc/conf.d/multiskkserv manually."
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
}