summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-08-29 21:54:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-08-29 22:01:54 +0900
commitbe2425c1fcee50d8fe6b574ac0485883d08809b4 (patch)
tree3b2fbf94788d3f7ff5805941405e7da3882f50ce /app-i18n/nabi
parentapp-i18n/nabi: drop old (diff)
downloadgentoo-be2425c1fcee50d8fe6b574ac0485883d08809b4.tar.gz
gentoo-be2425c1fcee50d8fe6b574ac0485883d08809b4.tar.bz2
gentoo-be2425c1fcee50d8fe6b574ac0485883d08809b4.zip
app-i18n/nabi: tidy
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n/nabi')
-rw-r--r--app-i18n/nabi/nabi-1.0.0.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/app-i18n/nabi/nabi-1.0.0.ebuild b/app-i18n/nabi/nabi-1.0.0.ebuild
index b9c453f52723..180520556c4d 100644
--- a/app-i18n/nabi/nabi-1.0.0.ebuild
+++ b/app-i18n/nabi/nabi-1.0.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="6"
inherit autotools
@@ -14,43 +14,38 @@ SLOT="0"
IUSE="debug nls"
KEYWORDS="~amd64 ~ppc ~x86"
-RDEPEND=">=app-i18n/libhangul-0.1.0
+RDEPEND=">=app-i18n/libhangul-0.1
dev-libs/glib:2
- x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-2.4:2
+ x11-libs/gtk+:2
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- x11-libs/pango
virtual/libintl"
DEPEND="${RDEPEND}
virtual/pkgconfig
sys-devel/gettext"
+S="${WORKDIR}/${PN}-${P}"
DOCS=( AUTHORS ChangeLog.0 NEWS README TODO )
-S="${WORKDIR}"/${PN}-${P}
-
src_prepare() {
default
eautoreconf
}
src_configure() {
- local myconf=
-
+ local myconf=()
# Broken configure: --disable-debug also enables debug
- use debug && \
- myconf="${myconf} --enable-debug"
+ use debug && myconf+=( --enable-debug )
- econf ${myconf}
+ econf "${myconf[@]}"
}
src_install() {
default
insinto /etc/X11/xinit/xinput.d
- sed -e "s:@EPREFIX@:${EPREFIX}:g" "${FILESDIR}/xinput-${PN}" | newins - "${PN}.conf"
+ sed -e "s:@EPREFIX@:${EPREFIX}:g" "${FILESDIR}"/xinput-${PN} | newins - ${PN}.conf
}
pkg_postinst() {