summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornilburn <nilburn+gentoo-bugs@gmail.com>2015-08-26 07:03:15 +0000
committerAkinori Hattori <hattya@gentoo.org>2018-07-31 21:31:54 +0900
commit1348200690ff829d9e909c71bf30375b19461472 (patch)
tree1b64a2aeffbfaab2a3290b040cce5b3aff40fa16 /app-i18n/nkf
parentapp-i18n/nkf: update to EAPI 6 (diff)
downloadgentoo-1348200690ff829d9e909c71bf30375b19461472.tar.gz
gentoo-1348200690ff829d9e909c71bf30375b19461472.tar.bz2
gentoo-1348200690ff829d9e909c71bf30375b19461472.zip
app-i18n/nkf: fix install with USE=perl
Closes: https://bugs.gentoo.org/558784 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-i18n/nkf')
-rw-r--r--app-i18n/nkf/nkf-2.1.3-r2.ebuild (renamed from app-i18n/nkf/nkf-2.1.3-r1.ebuild)11
-rw-r--r--app-i18n/nkf/nkf-2.1.3.ebuild68
2 files changed, 10 insertions, 69 deletions
diff --git a/app-i18n/nkf/nkf-2.1.3-r1.ebuild b/app-i18n/nkf/nkf-2.1.3-r2.ebuild
index 23f6161b3899..21daf284bc4f 100644
--- a/app-i18n/nkf/nkf-2.1.3-r1.ebuild
+++ b/app-i18n/nkf/nkf-2.1.3-r2.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge.jp/${PN}/59912/${P}.tar.gz
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-macos"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-macos"
IUSE="perl python l10n_ja"
src_prepare() {
@@ -33,6 +33,15 @@ src_prepare() {
default
}
+src_configure() {
+ default
+ if use perl; then
+ cd NKF.mod
+ perl-module_src_configure
+ cd - >/dev/null
+ fi
+}
+
src_compile() {
emake CC="$(tc-getCC)"
if use perl; then
diff --git a/app-i18n/nkf/nkf-2.1.3.ebuild b/app-i18n/nkf/nkf-2.1.3.ebuild
deleted file mode 100644
index 4c6a6142c01b..000000000000
--- a/app-i18n/nkf/nkf-2.1.3.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-inherit eutils distutils-r1 perl-module toolchain-funcs
-
-DESCRIPTION="Network Kanji code conversion Filter with UTF-8/16 support"
-HOMEPAGE="http://sourceforge.jp/projects/nkf/"
-SRC_URI="mirror://sourceforge.jp/nkf/59912/${P}.tar.gz
- python? ( https://dev.gentoo.org/~naota/files/NKF_python20090602.tgz )"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-macos"
-IUSE="perl python l10n_ja"
-
-src_prepare() {
- sed -i \
- -e '/^CFLAGS/{s|-g -O2||;s|=|+=|;}' \
- -e '/-o nkf/s:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' \
- Makefile || die
-
- if use python; then
- mv "${WORKDIR}/NKF.python" "${S}" || die
- epatch "${FILESDIR}"/${P}-strip.patch
- fi
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" nkf || die
- if use perl; then
- cd "${S}/NKF.mod"
- perl-module_src_compile
- fi
- if use python; then
- cd "${S}/NKF.python"
- distutils-r1_src_compile
- fi
-}
-
-src_test() {
- emake test || die
- if use perl; then
- cd "${S}/NKF.mod"
- perl-module_src_test
- fi
-}
-
-src_install() {
- dobin nkf || die
- doman nkf.1
-
- if use l10n_ja; then
- ./nkf -e nkf.1j > nkf.1
- doman -i18n=ja nkf.1
- fi
- dodoc nkf.doc
-
- if use perl; then
- cd "${S}/NKF.mod"
- perl-module_src_install
- fi
- if use python; then
- cd "${S}/NKF.python"
- distutils-r1_src_install
- fi
-}