summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-02-16 06:02:33 +0800
committerYixun Lan <dlan@gentoo.org>2017-02-16 06:04:29 +0800
commit1c2798b0e2ac813bc64a9a284549cc8c9f0dabbe (patch)
treef68481b65b3606bed11968a1809acb3f97e4e2a8 /app-i18n/opencc/opencc-1.0.5.ebuild
parentdev-tcltk/snack: ppc ppc64 stable (bug 593144). (diff)
downloadgentoo-1c2798b0e2ac813bc64a9a284549cc8c9f0dabbe.tar.gz
gentoo-1c2798b0e2ac813bc64a9a284549cc8c9f0dabbe.tar.bz2
gentoo-1c2798b0e2ac813bc64a9a284549cc8c9f0dabbe.zip
app-i18n/opencc: version bump, 1.0.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-i18n/opencc/opencc-1.0.5.ebuild')
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
new file mode 100644
index 000000000000..b8a9dfd27d32
--- /dev/null
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils multilib eutils vcs-snapshot
+
+DESCRIPTION="Libraries for conversion between Traditional and Simplified Chinese"
+HOMEPAGE="https://github.com/BYVoid/OpenCC"
+SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+DOCS="AUTHORS NEWS.md README.md"
+
+#PATCHES=(
+# "${FILESDIR}"/${PN}-1.0.4-cmake-libdir.patch
+#)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_GTEST=OFF
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}