summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-03 23:44:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-03 23:44:28 +0100
commit416254c17898b06b58964a07ce3e33a5686cae33 (patch)
tree3feffea1a853af93db2a4fcf4370140d1bb23373 /app-i18n/opencc
parentdev-perl/Cwd-Guard: Mark ~hppa (bug #593436). (diff)
downloadgentoo-416254c17898b06b58964a07ce3e33a5686cae33.tar.gz
gentoo-416254c17898b06b58964a07ce3e33a5686cae33.tar.bz2
gentoo-416254c17898b06b58964a07ce3e33a5686cae33.zip
Revert "app-i18n/opencc: Remove 0.3.0_pre20120819-r1"
This reverts commit 998b1baee2f85bb4d376d8e43272e6dca6c2fd21. This is still required by app-i18n/fcitx on stable ppc arch.
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/Manifest1
-rw-r--r--app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch17
-rw-r--r--app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild42
3 files changed, 60 insertions, 0 deletions
diff --git a/app-i18n/opencc/Manifest b/app-i18n/opencc/Manifest
index df3b997f88e7..f1ebb9c230d3 100644
--- a/app-i18n/opencc/Manifest
+++ b/app-i18n/opencc/Manifest
@@ -1 +1,2 @@
+DIST opencc-0.3.0_pre20120819.tar.xz 363528 SHA256 3ed46594547b86f1326b07c3ea910148b1c58b74c9d21c8d4e11ec30e2254fae SHA512 0ca231b5fd7b314111a76bfaa8e288fc2d43e02dbbb2a7c7e9312c1f1f0aed1a0d3b67b04b0cc3634d1b48b8fe6983e6219db053f3a2114abadec1af00b9f8d5 WHIRLPOOL 268d331479bffefdc6e1f58600422a36a32abb7d4dd873eeb216977daca05f4a4775ca547bb301bc16ea8fc702ef04cfd5d8f88c90d10e224a585575129e67c6
DIST opencc-1.0.4.tar.gz 1597309 SHA256 0553b7461ebd379d118d45d7f40f8a6e272750115bdbc49267595a05ee3481ac SHA512 682cc621fddb6495f26675863faefe7c9f584d2c60676cee0a3ff2120828a09a5e71671f5537030c2cc874f55b7f22af70d9d376f17b83e30cb04dcd5f6bba8a WHIRLPOOL 964180d27db85df6ffb4310ea6cae7b6c294c163bce68d05a5a21e8e736be6c11b44f8a2a856481b47e14c8c1104d244fc294259cbfa2f3160912743ac933cd6
diff --git a/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch b/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch
new file mode 100644
index 000000000000..76dc4330c440
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-0.3.0_pre20120819-cmake-libdir.patch
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -70,11 +70,11 @@ set (DIR_SHARE ${DIR_PREFIX}/share)
+ set (DIR_BIN ${DIR_PREFIX}/bin)
+ set (DIR_ETC ${DIR_PREFIX}/etc)
+
+ if (DEFINED CMAKE_INSTALL_LIBDIR)
+- set (DIR_LIBRARY ${CMAKE_INSTALL_LIBDIR})
+- set (DIR_LIBRARY_STATIC ${CMAKE_INSTALL_LIBDIR})
++ set (DIR_LIBRARY ${DIR_PREFIX}/${CMAKE_INSTALL_LIBDIR})
++ set (DIR_LIBRARY_STATIC ${DIR_PREFIX}/${CMAKE_INSTALL_LIBDIR})
+ endif (DEFINED CMAKE_INSTALL_LIBDIR)
+
+ if (DEFINED SHARE_INSTALL_PREFIX)
+ set (DIR_SHARE ${SHARE_INSTALL_PREFIX})
+ endif (DEFINED SHARE_INSTALL_PREFIX)
diff --git a/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild b/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild
new file mode 100644
index 000000000000..1d81dd28c572
--- /dev/null
+++ b/app-i18n/opencc/opencc-0.3.0_pre20120819-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils multilib eutils
+
+DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
+HOMEPAGE="https://github.com/BYVoid/OpenCC"
+SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="+nls static-libs"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+DOCS="AUTHORS README"
+
+src_prepare() {
+ sed -i \
+ -e "s:\${CMAKE_\(SHARED\|STATIC\)_LIBRARY_PREFIX}:\"$(get_libdir)\":" \
+ CMakeLists.txt || die
+ epatch "${FILESDIR}"/${P}-cmake-libdir.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable nls GETTEXT)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use static-libs || find "${ED}" -name '*.la' -o -name '*.a' -exec rm {} +
+}