summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/tomoe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/tomoe')
-rw-r--r--app-i18n/tomoe/Manifest1
-rw-r--r--app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch240
-rw-r--r--app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch39
-rw-r--r--app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch24
-rw-r--r--app-i18n/tomoe/metadata.xml12
-rw-r--r--app-i18n/tomoe/tomoe-0.6.0-r1.ebuild88
-rw-r--r--app-i18n/tomoe/tomoe-0.6.0-r2.ebuild93
7 files changed, 497 insertions, 0 deletions
diff --git a/app-i18n/tomoe/Manifest b/app-i18n/tomoe/Manifest
new file mode 100644
index 000000000000..7c7f067d37b4
--- /dev/null
+++ b/app-i18n/tomoe/Manifest
@@ -0,0 +1 @@
+DIST tomoe-0.6.0.tar.gz 4918949 SHA256 ee600f97fa434c13f6c41a1db9e03eccd551151ed48ece9c56cd9e828228ea1e SHA512 eab618d7b28fc9613c175fab6f80fc7d6acc34af3a47f20c11b42a32acd87143ae10caca67fa1a5e2e75441d431799a5725a5d507604f8bd7447bbc1826f0bb8 WHIRLPOOL f3cfb9bf09ab7228913a001348a73ea32d8f4cb25c941c5dd4829c237d0043f92293e2f914257902c1a5faf93d61fa82dfbea269d6b6d60cad49638cc6ca0141
diff --git a/app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch b/app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch
new file mode 100644
index 000000000000..2b2d98b6ddd7
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-0.6.0-export-symbols.patch
@@ -0,0 +1,240 @@
+Index: trunk/module/dict/tomoe-dict-xml.c
+===================================================================
+--- trunk/module/dict/tomoe-dict-xml.c (revision 1581)
++++ trunk/module/dict/tomoe-dict-xml.c (revision 1582)
+@@ -303,14 +303,14 @@
+ return success;
+
+ result.name = NULL;
+- result.chars = _tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
+- success = _tomoe_xml_parser_parse_dictionary_file (dict->filename, &result);
++ result.chars = tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
++ success = tomoe_xml_parser_parse_dictionary_file (dict->filename, &result);
+ if (result.name) {
+ g_free (dict->name);
+ dict->name = g_strdup (result.name);
+ g_free (result.name);
+ }
+- _tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
++ tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
+
+ return success;
+ }
+@@ -343,7 +343,7 @@
+ else
+ g_string_append (xml, "<dictionary>\n");
+
+- chars = _tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
++ chars = tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (dict));
+ for (i = 0; i < chars->len; i++) {
+ gchar *chr_xml;
+ TomoeChar *chr = g_ptr_array_index (chars, i);
+Index: trunk/module/dict/tomoe-dict-unihan.c
+===================================================================
+--- trunk/module/dict/tomoe-dict-unihan.c (revision 1581)
++++ trunk/module/dict/tomoe-dict-unihan.c (revision 1582)
+@@ -193,7 +193,7 @@
+ object = klass->constructor (type, n_props, props);
+ the_singleton = TOMOE_DICT_UNIHAN (object);
+
+- chars = _tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (object));
++ chars = tomoe_dict_ptr_array_get_array (TOMOE_DICT_PTR_ARRAY (object));
+ _tomoe_unihan_create (chars);
+ } else {
+ object = g_object_ref (G_OBJECT (the_singleton));
+Index: trunk/lib/tomoe-char.c
+===================================================================
+--- trunk/lib/tomoe-char.c (revision 1581)
++++ trunk/lib/tomoe-char.c (revision 1582)
+@@ -143,7 +143,7 @@
+ TomoeChar*
+ tomoe_char_new_from_xml_data (const gchar *data, gssize len)
+ {
+- return _tomoe_xml_parser_parse_char_data (data, len);
++ return tomoe_xml_parser_parse_char_data (data, len);
+ }
+
+ static void
+Index: trunk/lib/tomoe-xml-parser.c
+===================================================================
+--- trunk/lib/tomoe-xml-parser.c (revision 1581)
++++ trunk/lib/tomoe-xml-parser.c (revision 1582)
+@@ -428,8 +428,8 @@
+ }
+
+ gboolean
+-_tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
+- TomoeXMLParsedData *result)
++tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
++ TomoeXMLParsedData *result)
+ {
+ GMarkupParseContext *context;
+ FILE *f;
+@@ -469,7 +469,7 @@
+ }
+
+ TomoeChar *
+-_tomoe_xml_parser_parse_char_data (const gchar *xml, gssize len)
++tomoe_xml_parser_parse_char_data (const gchar *xml, gssize len)
+ {
+ GMarkupParseContext *context;
+ TomoeXMLParsedData result;
+Index: trunk/lib/tomoe-xml-parser.h
+===================================================================
+--- trunk/lib/tomoe-xml-parser.h (revision 1581)
++++ trunk/lib/tomoe-xml-parser.h (revision 1582)
+@@ -37,10 +37,10 @@
+ GPtrArray *chars;
+ };
+
+-gboolean _tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
+- TomoeXMLParsedData *result);
+-TomoeChar *_tomoe_xml_parser_parse_char_data (const gchar *xml,
+- gssize len);
++gboolean tomoe_xml_parser_parse_dictionary_file (const gchar *filename,
++ TomoeXMLParsedData *result);
++TomoeChar *tomoe_xml_parser_parse_char_data (const gchar *xml,
++ gssize len);
+
+
+ G_END_DECLS
+Index: trunk/lib/tomoe-dict-ptr-array.c
+===================================================================
+--- trunk/lib/tomoe-dict-ptr-array.c (revision 1581)
++++ trunk/lib/tomoe-dict-ptr-array.c (revision 1582)
+@@ -50,7 +50,7 @@
+
+ static TomoeDictClass *parent_class;
+
+-G_DEFINE_ABSTRACT_TYPE (TomoeDictPtrArray, _tomoe_dict_ptr_array, TOMOE_TYPE_DICT)
++G_DEFINE_ABSTRACT_TYPE (TomoeDictPtrArray, tomoe_dict_ptr_array, TOMOE_TYPE_DICT)
+
+ static void dispose (GObject *object);
+ static void set_property (GObject *object,
+@@ -75,7 +75,7 @@
+ static gchar *get_available_private_utf8 (TomoeDict *dict);
+
+ static void
+-_tomoe_dict_ptr_array_class_init (TomoeDictPtrArrayClass *klass)
++tomoe_dict_ptr_array_class_init (TomoeDictPtrArrayClass *klass)
+ {
+ GObjectClass *gobject_class;
+ TomoeDictClass *dict_class;
+@@ -123,7 +123,7 @@
+ }
+
+ static void
+-_tomoe_dict_ptr_array_init (TomoeDictPtrArray *dict)
++tomoe_dict_ptr_array_init (TomoeDictPtrArray *dict)
+ {
+ TomoeDictPtrArrayPrivate *priv = TOMOE_DICT_PTR_ARRAY_GET_PRIVATE (dict);
+ priv->chars = g_ptr_array_new();
+@@ -196,7 +196,7 @@
+ }
+
+ void
+-_tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict)
++tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict)
+ {
+ TomoeDictPtrArrayPrivate *priv;
+
+@@ -219,7 +219,7 @@
+
+ unregister_char (dict, tomoe_char_get_utf8 (chr));
+ g_ptr_array_add (priv->chars, g_object_ref (G_OBJECT (chr)));
+- _tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
++ tomoe_dict_ptr_array_sort (TOMOE_DICT_PTR_ARRAY (dict));
+
+ priv->modified = TRUE;
+
+@@ -449,7 +449,7 @@
+ g_ptr_array_add (*dest_chars, tomoe_char_dup (chr));
+ }
+
+-gboolean
++static gboolean
+ copy (TomoeDict *src_dict, TomoeDict *dest_dict)
+ {
+ TomoeDictPtrArrayPrivate *src_priv, *dest_priv;
+@@ -487,7 +487,7 @@
+ return TOMOE_DICT_PTR_ARRAY_GET_PRIVATE (dict)->editable;
+ }
+
+-gchar *
++static gchar *
+ get_available_private_utf8 (TomoeDict *dict)
+ {
+ TomoeDictPtrArrayPrivate *priv;
+@@ -523,7 +523,7 @@
+ }
+
+ GPtrArray *
+-_tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict)
++tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict)
+ {
+ g_return_val_if_fail (TOMOE_IS_DICT_PTR_ARRAY (dict), NULL);
+
+Index: trunk/lib/tomoe-dict-ptr-array.h
+===================================================================
+--- trunk/lib/tomoe-dict-ptr-array.h (revision 1581)
++++ trunk/lib/tomoe-dict-ptr-array.h (revision 1582)
+@@ -29,7 +29,7 @@
+
+ #include "tomoe-dict.h"
+
+-#define TOMOE_TYPE_DICT_PTR_ARRAY (_tomoe_dict_ptr_array_get_type ())
++#define TOMOE_TYPE_DICT_PTR_ARRAY (tomoe_dict_ptr_array_get_type ())
+ #define TOMOE_DICT_PTR_ARRAY(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), TOMOE_TYPE_DICT_PTR_ARRAY, TomoeDictPtrArray))
+ #define TOMOE_DICT_PTR_ARRAY_CLASS(klass) (G_TYPE_CHECK_CLASS_CAST ((klass), TOMOE_TYPE_DICT_PTR_ARRAY, TomoeDictPtrArrayClass))
+ #define TOMOE_IS_DICT_PTR_ARRAY(obj) (G_TYPE_CHECK_INSTANCE_TYPE ((obj), TOMOE_TYPE_DICT_PTR_ARRAY))
+@@ -49,9 +49,9 @@
+ TomoeDictClass parent_class;
+ };
+
+-GType _tomoe_dict_ptr_array_get_type (void) G_GNUC_CONST;
+-void _tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict);
+-GPtrArray *_tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict);
++GType tomoe_dict_ptr_array_get_type (void) G_GNUC_CONST;
++void tomoe_dict_ptr_array_sort (TomoeDictPtrArray *dict);
++GPtrArray *tomoe_dict_ptr_array_get_array (TomoeDictPtrArray *dict);
+
+ G_END_DECLS
+
+Index: trunk/lib/Makefile.am
+===================================================================
+--- trunk/lib/Makefile.am (revision 1581)
++++ trunk/lib/Makefile.am (revision 1582)
+@@ -30,13 +30,15 @@
+ tomoe-context.h \
+ tomoe-config.h \
+ tomoe-dict.h \
++ tomoe-dict-ptr-array.h \
+ tomoe-module.h \
+ tomoe-module-impl.h \
+ tomoe-query.h \
+ tomoe-reading.h \
+ tomoe-recognizer.h \
+ tomoe-shelf.h \
+- tomoe-writing.h
++ tomoe-writing.h \
++ tomoe-xml-parser.h
+
+ enum_source_prefix = tomoe-enum-types
+
+@@ -103,15 +105,13 @@
+ tomoe-config.c \
+ tomoe-dict.c \
+ tomoe-dict-ptr-array.c \
+- tomoe-dict-ptr-array.h \
+ tomoe-module.c \
+ tomoe-query.c \
+ tomoe-reading.c \
+ tomoe-recognizer.c \
+ tomoe-shelf.c \
+ tomoe-writing.c \
+- tomoe-xml-parser.c \
+- tomoe-xml-parser.h
++ tomoe-xml-parser.c
+
+ libtomoe_la_LDFLAGS = \
+ -version-info $(LT_VERSION_INFO) \
diff --git a/app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch b/app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch
new file mode 100644
index 000000000000..cf073d4d2cfa
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-0.6.0-glib232.patch
@@ -0,0 +1,39 @@
+diff --git a/lib/glib-compat-key-file.h b/lib/glib-compat-key-file.h
+index 6cae16b..1fb1490 100644
+--- a/lib/glib-compat-key-file.h
++++ b/lib/glib-compat-key-file.h
+@@ -51,7 +51,7 @@
+ #ifndef __G_KEY_FILE_H__
+ #define __G_KEY_FILE_H__
+
+-#include <glib/gerror.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff --git a/lib/glib-utils.h b/lib/glib-utils.h
+index 275c96c..7afca67 100644
+--- a/lib/glib-utils.h
++++ b/lib/glib-utils.h
+@@ -28,7 +28,7 @@
+ #include "config.h"
+ #endif /* HAVE_CONFIG_H */
+
+-#include <glib/garray.h>
++#include <glib.h>
+ #include <glib/gi18n-lib.h>
+ #include "glib-compat-file-utilities.h"
+ #include "glib-compat-key-file.h"
+diff --git a/lib/tomoe.c b/lib/tomoe.c
+index 8578c27..4534017 100644
+--- a/lib/tomoe.c
++++ b/lib/tomoe.c
+@@ -26,7 +26,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <glib/garray.h>
++#include <glib.h>
+ #include "tomoe.h"
+
+ static gboolean initialized = FALSE;
diff --git a/app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch b/app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch
new file mode 100644
index 000000000000..97ddc88f6ad3
--- /dev/null
+++ b/app-i18n/tomoe/files/tomoe-0.6.0-ldflags.patch
@@ -0,0 +1,24 @@
+diff -Naur tomoe-0.6.0.orig/module/dict/Makefile.am tomoe-0.6.0/module/dict/Makefile.am
+--- tomoe-0.6.0.orig/module/dict/Makefile.am 2007-06-18 10:35:40.000000000 +0900
++++ tomoe-0.6.0/module/dict/Makefile.am 2011-05-26 08:47:24.279701286 +0900
+@@ -34,7 +34,7 @@
+
+ LIBADD = $(TOMOE_LIBS) \
+ $(top_builddir)/lib/libtomoe.la
+-LDFLAGS = \
++LDFLAGS += \
+ -rpath $(dict_moduledir) -avoid-version -module \
+ -export-dynamic $(no_undefined) $(LIBTOOL_EXPORT_OPTIONS)
+
+diff -Naur tomoe-0.6.0.orig/module/recognizer/Makefile.am tomoe-0.6.0/module/recognizer/Makefile.am
+--- tomoe-0.6.0.orig/module/recognizer/Makefile.am 2007-04-10 16:24:20.000000000 +0900
++++ tomoe-0.6.0/module/recognizer/Makefile.am 2011-05-26 08:47:36.502740712 +0900
+@@ -23,7 +23,7 @@
+ AM_CPPFLAGS =
+ INCLUDES = $(TOMOE_CFLAGS)
+
+-LDFLAGS = \
++LDFLAGS += \
+ -rpath $(recognizer_moduledir) -avoid-version -module \
+ -export-dynamic $(no_undefined) $(LIBTOOL_EXPORT_OPTIONS)
+
diff --git a/app-i18n/tomoe/metadata.xml b/app-i18n/tomoe/metadata.xml
new file mode 100644
index 000000000000..1434dab816b8
--- /dev/null
+++ b/app-i18n/tomoe/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <use>
+ <flag name="hyperestraier">Enable support for
+ <pkg>app-text/hyperestraier</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">tomoe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild b/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..b2c5cbcf265b
--- /dev/null
+++ b/app-i18n/tomoe/tomoe-0.6.0-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+inherit autotools eutils multilib python
+
+DESCRIPTION="Japanese handwriting recognition engine"
+HOMEPAGE="http://tomoe.sourceforge.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc hyperestraier mysql ruby python static-libs subversion"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ruby? ( dev-ruby/ruby-glib2 )
+ hyperestraier? ( app-text/hyperestraier )
+ subversion? (
+ >=dev-libs/apr-1
+ dev-vcs/subversion
+ )
+ mysql? ( dev-db/mysql )
+ python? (
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ )"
+# test? ( app-dicts/uconv )
+
+DEPEND="${DEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ if use python ; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-export-symbols.patch" \
+ "${FILESDIR}/${P}-ldflags.patch" \
+ "${FILESDIR}/${P}-glib232.patch"
+
+ if ! use hyperestraier ; then
+ sed -i -e "s/use_est=yes/use_est=no/" configure.ac || die
+ fi
+ if ! use mysql ; then
+ sed -i -e "s/use_mysql=yes/use_mysql=no/" configure.ac || die
+ fi
+ if ! use subversion ; then
+ sed -i -e "s/use_svn=yes/use_svn=no/" macros/svn.m4 || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # --with-python b0rked
+ use python || myconf="${myconf} --without-python"
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_with ruby) \
+ $(use_enable static-libs static) \
+ $(use_enable ruby dict-ruby) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ find "${ED}/usr/$(get_libdir)/tomoe" \( -name '*.la' -o -name '*.a' \) -type f -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -type f -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS TODO || die
+}
diff --git a/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild b/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..e2b5eabf082f
--- /dev/null
+++ b/app-i18n/tomoe/tomoe-0.6.0-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools eutils multilib python-single-r1
+
+DESCRIPTION="Japanese handwriting recognition engine"
+HOMEPAGE="http://tomoe.sourceforge.jp/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc hyperestraier mysql ruby python static-libs subversion"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ruby? ( dev-ruby/ruby-glib2 )
+ hyperestraier? ( app-text/hyperestraier )
+ subversion? (
+ >=dev-libs/apr-1
+ dev-vcs/subversion
+ )
+ mysql? ( dev-db/mysql )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )"
+# test? ( app-dicts/uconv )
+
+DEPEND="${DEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RESTRICT="test"
+
+pkg_setup() {
+ if use python ; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-export-symbols.patch" \
+ "${FILESDIR}/${P}-ldflags.patch" \
+ "${FILESDIR}/${P}-glib232.patch"
+
+ if ! use hyperestraier ; then
+ sed -i -e "s/use_est=yes/use_est=no/" configure.ac || die
+ fi
+ if ! use mysql ; then
+ sed -i -e "s/use_mysql=yes/use_mysql=no/" configure.ac || die
+ fi
+ if ! use subversion ; then
+ sed -i -e "s/use_svn=yes/use_svn=no/" macros/svn.m4 || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # --with-python b0rked hard
+ unset PYTHON
+ use python || myconf="${myconf} --without-python"
+
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_with ruby) \
+ $(use_enable static-libs static) \
+ $(use_enable ruby dict-ruby) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ find "${ED}/usr/$(get_libdir)/tomoe" \( -name '*.la' -o -name '*.a' \) -type f -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -type f -delete || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS TODO || die
+}