summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-08-10 01:08:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:17 +0300
commit74436838a0da53e067c2bb8a80e21f2df13244ee (patch)
tree88267e5bd74a7c881648118b31eafd2002bc0145 /app-i18n/uchardet/uchardet-0.0.7.ebuild
parentsys-fs/simple-mtpfs: update fuse dependency slot (diff)
downloadgentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.tar.gz
gentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.tar.bz2
gentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.zip
app-i18n/uchardet: Version bump + maintainership
+ Added version 0.0.7, patch from 0.0.6-r2 isn't needed there + EAPI 6 -> 7 + Eclass cmake-utils -> cmake + I've adopted this orphaned package Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17066 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n/uchardet/uchardet-0.0.7.ebuild')
-rw-r--r--app-i18n/uchardet/uchardet-0.0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-i18n/uchardet/uchardet-0.0.7.ebuild b/app-i18n/uchardet/uchardet-0.0.7.ebuild
new file mode 100644
index 000000000000..777ebc8cfb7c
--- /dev/null
+++ b/app-i18n/uchardet/uchardet-0.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+if [ "${PV}" = 9999 ]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+else
+ SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+fi
+
+DESCRIPTION="An encoding detector library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_sse2 static-libs test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DTARGET_ARCHITECTURE="${ARCH}"
+ -DBUILD_STATIC=$(usex static-libs)
+ -DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+ cmake_src_configure
+}