summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-09-18 22:56:40 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-09-18 22:56:40 +0900
commit07bec84aa4f76bc2289b23b16a0c651fb7d3c3a5 (patch)
treedb07d598d86ebfe61f20ebb01496853bb22b2749 /app-i18n
parentapp-text/po4a: drop old (diff)
downloadgentoo-07bec84aa4f76bc2289b23b16a0c651fb7d3c3a5.tar.gz
gentoo-07bec84aa4f76bc2289b23b16a0c651fb7d3c3a5.tar.bz2
gentoo-07bec84aa4f76bc2289b23b16a0c651fb7d3c3a5.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.12.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 45b38112379d..8d3070752819 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.11.5.tar.gz 9485824 BLAKE2B 41d9aa2ba310e2db725e7809a67988fa69fee117b560d945a3cd935e7b2bbc372f448a531ed4ebd2a131dc1ffe3cb7d86b7d10fdbce56a2e241157f08a84ca69 SHA512 a30c81903b3d99f23a606f7f083615283ba64a0e62ac54183327447c33f6f7212472742036634522d36776a45ac72ce7874bcada624361f930785e2823652f0c
DIST ibus-typing-booster-2.14.0.tar.gz 10048272 BLAKE2B 638978811e6c7f4fa6607a7925aaf89636390391359c3e312a40ab759fff81066ea980995a3ec33f51dcb6fed5009d11bb90409c37b65c8f005b9769333e0cfb SHA512 5db5791e25caba4fa845c33198c20365c1e07cbbbfd6fe2d1d3145771b16031cc9baa55f950870fc11d4079ce04dac246603e45285550e856fc403342ae51676
+DIST ibus-typing-booster-2.14.12.tar.gz 10226257 BLAKE2B 5dae530a7ec425e8bd3c6009d0bdb9b8d321c8670769ddf80ba7f706d6b5140f21f184f877603de3cc6f425a4a1953c645eb177c9fa8183ecfd091ccfb32353a SHA512 09d1898c3ac8a1dc79768df7a44c33862a0b0fbb2122d184f1e8a839b8c3c71191fe5ef932f9e649ac715c8093a5c277d5783594f8defc06ecc13727b851ffa5
DIST ibus-typing-booster-2.14.4.tar.gz 10053545 BLAKE2B d0f941b937c1230ed9a947730fdc1bf9c3b5a255b1d3a63071fbe6c0595cf2d016aecaad4480770df34d1380c23b9db297fc57911dfb65e57952678593b2c05b SHA512 c8ab41fbc2bb401e342b317b0b20e0e9cd5c6ba529d0389b2b025db4295568b6f4ccadd639f622bd25078b6c2b8d5e336145c5397c580fb13012d4072333f523
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.12.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.12.ebuild
new file mode 100644
index 000000000000..4e8cb0ffc7f7
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}