summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-02-08 18:13:11 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-02-08 18:14:46 +0900
commit42aeedc037b6ccd47576e5d8e5a3d18f7ea6b70b (patch)
tree127a555fe2d4ce9a3d95117f6faf5dae79452bca /app-i18n
parentprofiles/arch/sparc: mask non-keyworded dep (diff)
downloadgentoo-42aeedc037b6ccd47576e5d8e5a3d18f7ea6b70b.tar.gz
gentoo-42aeedc037b6ccd47576e5d8e5a3d18f7ea6b70b.tar.bz2
gentoo-42aeedc037b6ccd47576e5d8e5a3d18f7ea6b70b.zip
app-i18n/ibus-typing-booster: new upstream release
Closes: https://bugs.gentoo.org/706228 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index e688dbe05e53..929485a8b1c8 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.6.0.tar.gz 6863400 BLAKE2B e399ebaa19a2949882de41cb3b11dfc161a0ddb300e23daf216857dea9bb4b3d31db6dcd02846214b8ac677df92672a342c7c9e992ab791f97bdf8abc514ba4a SHA512 7e916eaba5d3f14bde383acedd5ce9cd74e72328f25a84936055ee9183b4aeff79d5297fffdd27713491f23a949377cafc39bc52efa0f7d5995672176cb808c8
DIST ibus-typing-booster-2.7.0.tar.gz 7364094 BLAKE2B 60a45121b398032b2581d1f3e5929e74e69ee22bf0807b069529afb30797daacece47e83b0696397e6b9c3f6adc28012c7f2b7102387e03eb360383946e836b2 SHA512 a11d2cad660dc813022eda89bb690e3fe7cd517ad6a3cbc7f31879afb60c5d1628f25beb423f922b26d7dd92c685471c767084cdd3a35aff1e2314a21cd757c1
+DIST ibus-typing-booster-2.8.0.tar.gz 8018809 BLAKE2B 9306b980623094a8b72d6824292d8d52a90df69b7f1f7df11c0df63c5d2c4f2aa1ca4e2765320096915b30cc807fbe24f64a219c3beb1bec4a1d81be4511779a SHA512 64c112275ec63ac3d3c13202256be8bfded152da7b08dde7e6eb01dd38fd48535d63daaa6c2fcc09e64dcd4927931380ccd0a0be739f04330fb15dc0d4fe1823
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
new file mode 100644
index 000000000000..0845963503ce
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit python-single-r1
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="${PYTHON_DEPS}
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-libs/m17n-lib
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-db/m17n-db-1.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"