summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2021-09-26 05:13:01 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2021-09-26 05:56:43 +0700
commit5512fe298f5d656fd8c14fe40d306af22fbdd8ae (patch)
tree0962653c482634e22baaebb956ce2afdbd69a45b /app-i18n
parentapp-i18n/unicode-cldr: new version (diff)
downloadgentoo-5512fe298f5d656fd8c14fe40d306af22fbdd8ae.tar.gz
gentoo-5512fe298f5d656fd8c14fe40d306af22fbdd8ae.tar.bz2
gentoo-5512fe298f5d656fd8c14fe40d306af22fbdd8ae.zip
app-i18n/unicode-data: move data to common path
Package-Manager: Portage-3.0.23, Repoman-3.0.1 Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/unicode-data/unicode-data-14.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-i18n/unicode-data/unicode-data-14.0.0-r1.ebuild b/app-i18n/unicode-data/unicode-data-14.0.0-r1.ebuild
new file mode 100644
index 000000000000..d31503087bd1
--- /dev/null
+++ b/app-i18n/unicode-data/unicode-data-14.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Unicode data from unicode.org"
+HOMEPAGE="https://unicode.org/ucd/"
+SRC_URI="https://unicode.org/Public/zipped/${PV}/UCD.zip -> ${P}-UCD.zip
+ https://unicode.org/Public/zipped/${PV}/Unihan.zip -> ${P}-Unihan.zip"
+
+LICENSE="unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="app-arch/unzip"
+S="${WORKDIR}"
+
+src_prepare() {
+ # we have separate ebuild for emoji. And it is even more complete that what installs here.
+ rm -r emoji || die
+ default
+}
+
+src_install() {
+ insinto /usr/share/${PN%%-*}
+ doins -r "${S}"/*
+ # Unihan.zip needs to be installed as a zip for reverse deps
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210
+ newins "${DISTDIR}"/${P}-Unihan.zip Unihan.zip
+}