summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-06-20 21:50:54 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-06-20 21:50:54 +0900
commit90440930519b0790fd4a16d1161f3b0d722c1036 (patch)
treead6d625f851bbb90e2afe04c1f134690f6d6e0f6 /app-i18n
parentapp-i18n/ibus-table: new upstream release (diff)
downloadgentoo-90440930519b0790fd4a16d1161f3b0d722c1036.tar.gz
gentoo-90440930519b0790fd4a16d1161f3b0d722c1036.tar.bz2
gentoo-90440930519b0790fd4a16d1161f3b0d722c1036.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.16.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index e8c0d2d19661..f2c3ef3613a5 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.15.25.tar.gz 10785373 BLAKE2B 555105c9da7a813491e3ab8cbea0a8b52239c7ffb39dc7a6ea47e461d81515ba3cdf1adfe8d8cebd74bb2b00775eac3b19956aa9e4c4b696e6083418e2b73e91 SHA512 927f118eac1a641f658b82ef72ec8cd728727910f6c2bd77a14d9195a8203fd40b771e68a04d7ea7c5f5c1f2cd4ff37b7e041282e63f301348b60af462e041ea
DIST ibus-typing-booster-2.16.0.tar.gz 10811558 BLAKE2B d171972f3c6242234ce73112e4ea8fde9e713e102a7fb2111017e7489811c1128146582e2a9a60f49dfca8b5282949415fb33e79b7c1be16521dba2dd03536fa SHA512 a90ea11a72d770765ef55ff6fc288bf6ddfa5e5ae1c7393f195ed3466a207022872f5e27f9629101b8b31e26c84dc8512e4cd261b2c503fd98daa8438e47dfb9
+DIST ibus-typing-booster-2.16.3.tar.gz 10815318 BLAKE2B 66c58060494fdd2f459c68374bf1c0a5d70b76e1ad07f2daa14c9459c20574e1f6737ab7a516233ef70ffa8f1ea9a3b98def7f17adaab5bb0111fa4ebc6d2aa2 SHA512 658eb972136c16dd703fa8b0e378d4ca511ba7a80ace39617eed7939607e37b7f94eaf6560514a474aec47e40d415fe3733728617237751c132ef17e46be963c
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.16.3.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.16.3.ebuild
new file mode 100644
index 000000000000..58166b805e3c
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.16.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}