summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-19 00:24:28 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-19 00:24:28 +0900
commit9647a5ca1f865b4b5f9332be9d248a64786681ed (patch)
treeb8d60c9e8715bbe2315d5c6491e4b9ed9cb8fd9c /app-i18n
parentapp-i18n/kinput2: fix implicit declarations (diff)
downloadgentoo-9647a5ca1f865b4b5f9332be9d248a64786681ed.tar.gz
gentoo-9647a5ca1f865b4b5f9332be9d248a64786681ed.tar.bz2
gentoo-9647a5ca1f865b4b5f9332be9d248a64786681ed.zip
app-i18n/kinput2: fix build with app-i18n/freewnn
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/kinput2/files/kinput2-wnn.patch51
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r1.ebuild1
-rw-r--r--app-i18n/kinput2/kinput2-3.1-r2.ebuild1
3 files changed, 53 insertions, 0 deletions
diff --git a/app-i18n/kinput2/files/kinput2-wnn.patch b/app-i18n/kinput2/files/kinput2-wnn.patch
new file mode 100644
index 000000000000..4e7001938fb2
--- /dev/null
+++ b/app-i18n/kinput2/files/kinput2-wnn.patch
@@ -0,0 +1,51 @@
+--- a/lib/cconv.c
++++ b/lib/cconv.c
+@@ -790,7 +790,7 @@
+ static int parseLine(uchar *, uchar **, int);
+ static FILE *openfile(char *);
+ static int doinclude(uchar *, Files *, void (*)());
+-static uchar *getline(uchar *, int, Files *, void (*)());
++static uchar *getLine(uchar *, int, Files *, void (*)());
+ static int readRuleFile(ccRule, char *);
+ static int registMode(ccRule, int, uchar **);
+ static int newMode(ccRule, Files *, _strbufRec *, _funcbufRec *,
+@@ -1035,8 +1035,8 @@
+ return 0;
+ }
+
+-/* getline -- 1$B9TFI$_9~$`(B ($B$=$N:](B include $B$N=hM}$r9T$J$&(B) */
+-static uchar *getline(line, linesize, files, efunc)
++/* getLine -- 1$B9TFI$_9~$`(B ($B$=$N:](B include $B$N=hM}$r9T$J$&(B) */
++static uchar *getLine(line, linesize, files, efunc)
+ uchar *line;
+ int linesize;
+ Files *files;
+@@ -1100,7 +1100,7 @@
+ rule->nmode = 0;
+ rule->initialmode = -1;
+
+- while (getline(line, sizeof(line), &files, efunc)) {
++ while (getLine(line, sizeof(line), &files, efunc)) {
+ (void)Strcpy(tmp, line);
+ if ((argc = parseLine(tmp, argv, 20)) == 0)
+ continue;
+@@ -1269,7 +1269,7 @@
+ cdbuf.cdbuf = NULL;
+
+ /* $B%k!<%k$rFI$s$G%9%H%"$9$k(B */
+- while (getline(line, sizeof(line), files, efunc)) {
++ while (getLine(line, sizeof(line), files, efunc)) {
+ /* '#' $B$G;O$^$k9T$O%3%a%s%H(B */
+ if (*line == '\0' || *line == '\n' || *line == '#')
+ continue;
+--- a/lib/wnnlib.c
++++ b/lib/wnnlib.c
+@@ -1367,7 +1367,7 @@
+
+ /* $BJQ49J8;zNs$ND9$5$N%A%'%C%/(B */
+ clp = buf->clauseInfo + cl;
+- len = jl_kanji_len(buf->wnn, cl);
++ len = jl_kanji_len(buf->wnn, cl, -1);
+ diff = len - ((clp + 1)->dispp - clp->dispp);
+ newlen = (buf->displayEnd - buf->displayBuf) + diff;
+ if (newlen > buf->bufferSize) {
diff --git a/app-i18n/kinput2/kinput2-3.1-r1.ebuild b/app-i18n/kinput2/kinput2-3.1-r1.ebuild
index caf4b59765b6..d18b1cdc75d1 100644
--- a/app-i18n/kinput2/kinput2-3.1-r1.ebuild
+++ b/app-i18n/kinput2/kinput2-3.1-r1.ebuild
@@ -36,6 +36,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-headers.patch
"${FILESDIR}"/${PN}-ppc.patch
"${FILESDIR}"/${PN}-segfault.patch
+ "${FILESDIR}"/${PN}-wnn.patch
)
DOCS=( README NEWS doc/. )
diff --git a/app-i18n/kinput2/kinput2-3.1-r2.ebuild b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
index 0f1fc47b2a4f..864011015526 100644
--- a/app-i18n/kinput2/kinput2-3.1-r2.ebuild
+++ b/app-i18n/kinput2/kinput2-3.1-r2.ebuild
@@ -36,6 +36,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-headers.patch
"${FILESDIR}"/${PN}-ppc.patch
"${FILESDIR}"/${PN}-segfault.patch
+ "${FILESDIR}"/${PN}-wnn.patch
)
DOCS=( README NEWS doc/. )