summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-03-23 23:43:43 +0100
committerMike Gilbert <floppym@gentoo.org>2016-03-24 10:42:46 -0400
commitace84ab1f93c5e714d763211c011d49879a7efd3 (patch)
tree9eec2d6e46d70e76b50472938cf618fdd2effbcc /app-i18n
parentapp-i18n/kcm-fcitx: Change SLOT of KDE-4-related ebuilds from "0" to "4". (diff)
downloadgentoo-ace84ab1f93c5e714d763211c011d49879a7efd3.tar.gz
gentoo-ace84ab1f93c5e714d763211c011d49879a7efd3.tar.bz2
gentoo-ace84ab1f93c5e714d763211c011d49879a7efd3.zip
app-i18n/kcm-fcitx: Minor fixes in 0.4.3.
Use cmake-utils.eclass and xdg.eclass instead of kde4-base.eclass. Improve HOMEPAGE. Fix LICENSE. Add "minimal" USE flag to avoid collision of translations with app-i18n/kcm-fcitx:5. Fix dependencies.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild41
1 files changed, 34 insertions, 7 deletions
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild
index b930717b6284..ce2cd5087715 100644
--- a/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild
@@ -2,20 +2,47 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit kde4-base
+EAPI="5"
+
+inherit cmake-utils xdg
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+ EGIT_BRANCH="kde4"
+fi
DESCRIPTION="KDE configuration module for Fcitx"
-HOMEPAGE="http://fcitx-im.org/"
-SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
-LICENSE="GPL-3"
+LICENSE="GPL-2+"
SLOT="4"
KEYWORDS="amd64 ~ppc ppc64 ~x86"
-IUSE=""
+IUSE="minimal"
-RDEPEND=">=app-i18n/fcitx-4.2.8[qt4]
+RDEPEND=">=app-i18n/fcitx-4.2.8[dbus,qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ kde-base/kdelibs:4
+ virtual/libintl
+ x11-libs/libX11
x11-libs/libxkbfile"
DEPEND="${RDEPEND}
+ dev-util/automoc
sys-devel/gettext
virtual/pkgconfig"
+
+src_prepare() {
+ if use minimal; then
+ cmake_comment_add_subdirectory po
+ fi
+
+ cmake-utils_src_prepare
+}