summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-09-08 22:21:58 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-09-08 22:21:58 +0900
commitaea002e718eed9e4bcf822bfe2e1db6075f9d14e (patch)
treeb2cf2ff594deabc85e131c0694f677115cd1c76e /app-i18n
parentapp-i18n/ibus-m17n: drop old (diff)
downloadgentoo-aea002e718eed9e4bcf822bfe2e1db6075f9d14e.tar.gz
gentoo-aea002e718eed9e4bcf822bfe2e1db6075f9d14e.tar.bz2
gentoo-aea002e718eed9e4bcf822bfe2e1db6075f9d14e.zip
app-i18n/ibus-m17n: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-m17n/Manifest1
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-1.4.11.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-i18n/ibus-m17n/Manifest b/app-i18n/ibus-m17n/Manifest
index ddbdfffd42f8..12ea8c81fbfb 100644
--- a/app-i18n/ibus-m17n/Manifest
+++ b/app-i18n/ibus-m17n/Manifest
@@ -1 +1,2 @@
DIST ibus-m17n-1.4.10.tar.gz 642940 BLAKE2B f00b4392925a6ad24e5cbfc266d13a68e4b7641a4f70c93bb381d4bea13d03b40af659e2ba27533ce7514477aed2744eaac0b1aa25d7c4280fda8adf1ee5dde7 SHA512 7e8ab477de7fb75fbbcdd25d6f13b0dc1fdaae6ab23a2c5c18de7eadcd88c3ff4d441a32f58d4b4bde0d20685d45dd57fa24c5e61361ad5b6bbb29075949d396
+DIST ibus-m17n-1.4.11.tar.gz 644907 BLAKE2B 269f4f815b0bcce2ab0d15840b565cbce2037e4a307d2341333e66034d96d02fa6f9f2eae5e75477a7187af1f01e5b4f0f1db3327aa4b40bbce1a4e0ecb64b07 SHA512 f2fb4afc009ffee63b6f09e42fc6ec9528ba0b06c16d4371db8d2e4e4d0da1795bf6c28f8ccc5bad206b13181a98906eabb474adf331175636de2b8a0119a731
diff --git a/app-i18n/ibus-m17n/ibus-m17n-1.4.11.ebuild b/app-i18n/ibus-m17n/ibus-m17n-1.4.11.ebuild
new file mode 100644
index 000000000000..1466a2deebfc
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-1.4.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit gnome2-utils xdg
+
+DESCRIPTION="M17N engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk nls"
+
+DEPEND="app-i18n/ibus
+ dev-libs/m17n-lib
+ gtk? ( x11-libs/gtk+:3 )
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gtk 3.0)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}