summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-04-18 17:13:51 +0000
committerMike Gilbert <floppym@gentoo.org>2019-04-19 12:39:05 -0400
commitbe0cc9ea6caf1caa70a20368418a700afd6697e3 (patch)
treeeae2c5fe85a893e8cc0fe6cfce7833a6a3a0408f /app-i18n
parentapp-i18n/libpinyin: Update model version. (diff)
downloadgentoo-be0cc9ea6caf1caa70a20368418a700afd6697e3.tar.gz
gentoo-be0cc9ea6caf1caa70a20368418a700afd6697e3.tar.bz2
gentoo-be0cc9ea6caf1caa70a20368418a700afd6697e3.zip
app-i18n/libpinyin: Version bump (2.3.0).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/libpinyin/Manifest1
-rw-r--r--app-i18n/libpinyin/libpinyin-2.3.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-i18n/libpinyin/Manifest b/app-i18n/libpinyin/Manifest
index f53cd55d70a5..39d5c8a3ea2b 100644
--- a/app-i18n/libpinyin/Manifest
+++ b/app-i18n/libpinyin/Manifest
@@ -1,4 +1,5 @@
DIST libpinyin-2.2.1.tar.gz 256262 BLAKE2B 4fc081aa42b07eb7d21277c95407eafbf618c9aaf0c6707893f212be70f51d43fe00f50d1b4758d857d0f8aed1e9c177d61d6ca912e776633e8179279f09fb2e SHA512 d323655419aaceda12d794ac25387a2e073e8c2372511913febd5b8049f9d1764a0011cd97b538bbfb14f5c248495a150cf7e3b9f4af21182941e5920f2d879f
DIST libpinyin-2.2.2.tar.gz 256304 BLAKE2B 52dc7d8fb4836bfc23137ba96177d488bf425c4bce52ea68933fe873a4ec02e2d49ccfac5c6097b55ea676bed30e635fc9805c205892bba2fe6047d92e5b9ed7 SHA512 80d955bf7f9e85ea90f9469032507713b0e15290fb7cc91a471c8c5564e3c78d430c5fd1dc871693aa40688fb68f7a17f719defe107d1512c5bcefd290c56285
+DIST libpinyin-2.3.0.tar.gz 256549 BLAKE2B 621176ab14dfe8fb3c32e3ae0b727b8070b5fdcc3a79f8f3c646538151601c7fefe0b2778a54c50faabaf3026d9c029eaa52a0e04144d37f347ca571fd532908 SHA512 5cfe2d70c15dc532fa970a28b70da403f2d848747501bdbdf43c481f8165d6290cb1de086d2ef7af653edfe3fb164d4e8d9cf655302e2aa759709e6031b117b2
DIST libpinyin-model15.text.tar.gz 19361973 BLAKE2B 3d24321db407e28c1adf49373dd9bacafe0e89409511c0656d7b9a85f1d1ac8693249088dd99beef069576f4a8d0d5db3fd47f98822b32aa3098315cf2660d22 SHA512 d3f5b42f6ea6b22570b5ba67cf23d94a3fee2d7d894191ebc11eb72edc162c72b90b2fe10b312bfd8d77d110654ee5dc00c21b25fb8b7c3f905d4088c9895ac1
DIST libpinyin-model17.text.tar.gz 20278815 BLAKE2B d02a587ab29e1115843d8c2318ef70cf7c2318d5c60ef8135860c611935285fa0f061a21d7e85dd87f6efe957742e21e34a77a7b245b58945cdd478759b0e19f SHA512 d0bf8d476a63e33e292046754161316f00bfea71ebd06fca85b3845fe535431f01458282f505380cae018050aa6a08b14a7bc0684ba372dc79ee14391f47e8a1
diff --git a/app-i18n/libpinyin/libpinyin-2.3.0.ebuild b/app-i18n/libpinyin/libpinyin-2.3.0.ebuild
new file mode 100644
index 000000000000..ab8431af41fb
--- /dev/null
+++ b/app-i18n/libpinyin/libpinyin-2.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2012-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/libpinyin/libpinyin"
+fi
+
+LIBPINYIN_MODEL_VERSION="17"
+
+DESCRIPTION="Libraries for handling of Hanyu Pinyin and Zhuyin Fuhao"
+HOMEPAGE="https://github.com/libpinyin/libpinyin https://sourceforge.net/projects/libpinyin/"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+SRC_URI+=" mirror://sourceforge/${PN}/models/model${LIBPINYIN_MODEL_VERSION}.text.tar.gz -> ${PN}-model${LIBPINYIN_MODEL_VERSION}.text.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/13"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/glib:2
+ sys-libs/db:="
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if [[ "${PV}" == "9999" ]]; then
+ git-r3_src_unpack
+ else
+ unpack ${P}.tar.gz
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed -e "/^\twget .*\/model${LIBPINYIN_MODEL_VERSION}\.text\.tar\.gz$/d" -i data/Makefile.am || die
+ ln -s "${DISTDIR}/${PN}-model${LIBPINYIN_MODEL_VERSION}.text.tar.gz" "data/model${LIBPINYIN_MODEL_VERSION}.text.tar.gz" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-libzhuyin \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}