summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-03-23 23:29:14 +0100
committerMike Gilbert <floppym@gentoo.org>2016-03-24 10:42:46 -0400
commitc9826beb7b8b2965d2e3cc346056e89ca3f5d894 (patch)
tree99bbc5f420e20c3ae4eaf49f7d5c1e904f8014f4 /app-i18n
parentapp-i18n/fcitx-qt5: Version bump (1.0.5). (diff)
downloadgentoo-c9826beb7b8b2965d2e3cc346056e89ca3f5d894.tar.gz
gentoo-c9826beb7b8b2965d2e3cc346056e89ca3f5d894.tar.bz2
gentoo-c9826beb7b8b2965d2e3cc346056e89ca3f5d894.zip
app-i18n/fcitx-qt5: Add live ebuild.
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-9999.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-9999.ebuild
new file mode 100644
index 000000000000..6af0341cebba
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-qt5"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-qt5"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+
+DOCS=()