summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adi@adirat.com>2015-11-11 20:37:47 +0200
committerIoan-Adrian Ratiu <adi@adirat.com>2015-11-12 12:58:40 +0200
commit4b4234a933a25f93131c443b51cc3bd5b79ce345 (patch)
tree2589bb4ea22ea08f1fd2385c94d0f63fa6d6a03d /app-laptop/i8kutils/files
parentdev-python/pylint: Depend on threading support in python (diff)
downloadgentoo-4b4234a933a25f93131c443b51cc3bd5b79ce345.tar.gz
gentoo-4b4234a933a25f93131c443b51cc3bd5b79ce345.tar.bz2
gentoo-4b4234a933a25f93131c443b51cc3bd5b79ce345.zip
app-laptop/i8kutils: fix gcc5 build for v1.42
Recipe enhancements requested in the bug are also included Gentoo bug: #565466 Signed-off-by: Ioan-Adrian Ratiu <adi@adirat.com>
Diffstat (limited to 'app-laptop/i8kutils/files')
-rw-r--r--app-laptop/i8kutils/files/i8kutils-1.42-Makefile.patch34
-rw-r--r--app-laptop/i8kutils/files/i8kutils-gcc5.patch28
2 files changed, 62 insertions, 0 deletions
diff --git a/app-laptop/i8kutils/files/i8kutils-1.42-Makefile.patch b/app-laptop/i8kutils/files/i8kutils-1.42-Makefile.patch
new file mode 100644
index 000000000000..7dc56d91aa3e
--- /dev/null
+++ b/app-laptop/i8kutils/files/i8kutils-1.42-Makefile.patch
@@ -0,0 +1,34 @@
+Fix a race condition causing parallel builds to sometimes fail.
+
+Both probe_i8k_calls_time and i8kctl contain a main() function, though
+i8kctl's is omitted when built with -DLIB so they can link without a
+conflict. i8kctl is also a standalone exe so it is built twice, with
+and without -DLIB. When building in parallel you can get into a
+situation where the object file created by the probe_i8k_calls_time
+target gets overwritten with the one from i8kctl and bad things happen.
+Nothing actually uses the i8kctl.o that has main() so we can just not
+build it.
+
+Also move CFLAGS, CC, LDFLAGS respect out of the ebuild.
+
+--- a/Makefile
++++ b/Makefile
+@@ -17,13 +17,13 @@ ccflags-y = -Wall
+
+ all: i8kctl probe_i8k_calls_time
+
+-i8kctl: i8kctl.c i8kctl.o
+- gcc -Wall i8kctl.c -o i8kctl
++i8kctl: i8kctl.c
++ $(CC) -Wall ${CFLAGS} -o i8kctl i8kctl.c
+
+ probe_i8k_calls_time: probe_i8k_calls_time.c
+- gcc -Wall -c -g -DLIB i8kctl.c
+- gcc -Wall -c -g -DLIB probe_i8k_calls_time.c
+- gcc -o probe_i8k_calls_time i8kctl.o probe_i8k_calls_time.o
++ $(CC) -Wall ${CFLAGS} -c -DLIB i8kctl.c
++ $(CC) -Wall ${CFLAGS} -c -DLIB probe_i8k_calls_time.c
++ $(CC) -Wall ${CFLAGS} ${LDFLAGS} -o probe_i8k_calls_time i8kctl.o probe_i8k_calls_time.o
+
+ i8k:
+ make -C /lib/modules/$(shell uname -r)/build M=$(PWD) modules
diff --git a/app-laptop/i8kutils/files/i8kutils-gcc5.patch b/app-laptop/i8kutils/files/i8kutils-gcc5.patch
new file mode 100644
index 000000000000..258b95f595f6
--- /dev/null
+++ b/app-laptop/i8kutils/files/i8kutils-gcc5.patch
@@ -0,0 +1,28 @@
+Fix build with GCC 5.
+
+x86_64-pc-linux-gnu-gcc -O2 -march=native -g -pipe -c -o i8kctl.o i8kctl.c
+gcc -Wall -c -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed -DLIB i8kctl.c
+gcc -Wall -c -Wl,--hash-style=gnu -Wl,-O1 -Wl,--as-needed -DLIB probe_i8k_calls_time.c
+gcc -o probe_i8k_calls_time i8kctl.o probe_i8k_calls_time.o
+probe_i8k_calls_time.o: In function `main':
+probe_i8k_calls_time.c:(.text+0x62): undefined reference to `timestamp'
+probe_i8k_calls_time.c:(.text+0x82): undefined reference to `timestamp'
+probe_i8k_calls_time.c:(.text+0xa2): undefined reference to `timestamp'
+probe_i8k_calls_time.c:(.text+0xbf): undefined reference to `timestamp'
+probe_i8k_calls_time.c:(.text+0xdc): undefined reference to `timestamp'
+probe_i8k_calls_time.o:probe_i8k_calls_time.c:(.text+0xf9): more undefined references to `timestamp' follow
+collect2: error: ld returned 1 exit status
+Makefile:24: recipe for target 'probe_i8k_calls_time' failed
+
+
+--- a/probe_i8k_calls_time.c
++++ b/probe_i8k_calls_time.c
+@@ -13,7 +13,7 @@ double t;
+
+ struct timespec tmst;
+
+-inline double timestamp()
++double timestamp()
+ {
+ clock_gettime(CLOCK_REALTIME, &tmst);
+ t = tmst.tv_nsec;