summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2018-04-04 09:33:38 +0200
committerChristoph Junghans <junghans@gentoo.org>2018-06-10 12:17:12 -0600
commit99cc1546b234910e0c1ef671e2449c68815687fe (patch)
treeffe2eefc3280a38d39e81b2916dd27994d6c7be3 /app-laptop/tpacpi-bat
parentdev-perl/Sereal-Encoder: stable 4.4.0 for ia64, bug #657574 (diff)
downloadgentoo-99cc1546b234910e0c1ef671e2449c68815687fe.tar.gz
gentoo-99cc1546b234910e0c1ef671e2449c68815687fe.tar.bz2
gentoo-99cc1546b234910e0c1ef671e2449c68815687fe.zip
app-laptop/tpacpi-bat: bump to version 3.1
Bug: https://github.com/gentoo/gentoo/pull/7803 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Henning Schild <henning@hennsch.de>
Diffstat (limited to 'app-laptop/tpacpi-bat')
-rw-r--r--app-laptop/tpacpi-bat/Manifest1
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild34
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild7
3 files changed, 39 insertions, 3 deletions
diff --git a/app-laptop/tpacpi-bat/Manifest b/app-laptop/tpacpi-bat/Manifest
index 1b0a4d4049a7..90b6bd0984e4 100644
--- a/app-laptop/tpacpi-bat/Manifest
+++ b/app-laptop/tpacpi-bat/Manifest
@@ -1,3 +1,4 @@
DIST tpacpi-bat-1.1.tar.gz 17781 BLAKE2B 73e9cef77f5eb889e653dab05b3f9502795833221d007319abad0017b70dc3c60d1a2e7649f1003e9eb16da94efa185b195e42789b528b5c5b62738abaff9e3a SHA512 7b8838e6db7f98cd5bb674a99dbb880ba6574529de68d97ce704bf225ba416183971aae3c2dd623bc8750767c54a2a52cd0b525bce70640ecf0b307fdba03821
DIST tpacpi-bat-2.1.tar.gz 17753 BLAKE2B c470cfdb98c2873ca44dad9cb0fc31e6bc97c8832735003b707ee191c65dba3cd9c0422513b4a93aae26692a154675cb94e02d30b721d498610bf21711bcf1e6 SHA512 7ed4974d84c3f1ddc9fd5cd6d7f103a11e2f808a223692749e3ae0ec2e888b62083d577214e27634cd76e9b616a6b8d5cb5474ddb64f73972d08641051c5c6f8
DIST tpacpi-bat-3.0.tar.gz 18137 BLAKE2B db0db2c06d5bc78eb028cb0db2532e5500cce2370c23ab3bf1e49433b83ed2be7cfffe080e46c3699838ff00025d516dd37e071081f79c7d5d6293f4f49730d4 SHA512 2beab3e5495f028b53d673a4243a2128f4ff85e19e18ac7d53663a1d62e20b271442d6c2c8f19cb41d618ddf7ebb4d9b8390f7f185f77bdca33c69bb19463128
+DIST tpacpi-bat-3.1.tar.gz 18584 BLAKE2B 5f1e890f33be4e0d176bda486d9e4363d56a7a933677eb69bedca9ec42e8af5a0e5494f8447702d33ffecda3d1d4a447a56f7aeb9480a3b855a24bce45028d38 SHA512 cdc9e0c0ded96281678199783b4c48ff85a497c90b244a7ce2276b54d7ae4bfa7eb430214bcdb6fabd7478796507b0fbe7fed4b1ab4bc4cdd7bd5ae25f943a77
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild
new file mode 100644
index 000000000000..6364a4ee745f
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dodoc README.md battery_asl
+ dobin tpacpi-bat
+ newinitd "${FILESDIR}"/${PN}.initd.2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.1 ${PN}
+ systemd_newunit examples/systemd_fixed_threshold/tpacpi.service \
+ ${PN}.service
+}
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
index c3feb204bff7..6364a4ee745f 100644
--- a/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,9 +25,10 @@ RDEPEND="sys-power/acpi_call
dev-lang/perl"
src_install() {
- dodoc README battery_asl
+ dodoc README.md battery_asl
dobin tpacpi-bat
newinitd "${FILESDIR}"/${PN}.initd.2 ${PN}
newconfd "${FILESDIR}"/${PN}.confd.1 ${PN}
- systemd_newunit tpacpi.service ${PN}.service
+ systemd_newunit examples/systemd_fixed_threshold/tpacpi.service \
+ ${PN}.service
}