summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Kaukov <peter@kaukov.dev>2023-04-12 14:05:39 +0300
committerSam James <sam@gentoo.org>2023-05-13 04:01:28 +0100
commit0b2ae9bb2ee3ed4d061a4c2e633a04bbcc197f70 (patch)
tree2c56d1ab3b8b48973cbdfd14681318cdbb122d62 /app-laptop
parentapp-laptop/tuxedo-control-center-bin: drop 1.1.4 (diff)
downloadgentoo-0b2ae9bb2ee3ed4d061a4c2e633a04bbcc197f70.tar.gz
gentoo-0b2ae9bb2ee3ed4d061a4c2e633a04bbcc197f70.tar.bz2
gentoo-0b2ae9bb2ee3ed4d061a4c2e633a04bbcc197f70.zip
app-laptop/tuxedo-keyboard: add 3.2.1
Closes: https://bugs.gentoo.org/902133 Signed-off-by: Peter Kaukov <peter@kaukov.dev> Closes: https://github.com/gentoo/gentoo/pull/30533 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tuxedo-keyboard/Manifest1
-rwxr-xr-xapp-laptop/tuxedo-keyboard/files/tuxedo-keyboard-3.2.1-rm-unused-functions.patch67
-rw-r--r--app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.1.ebuild24
3 files changed, 92 insertions, 0 deletions
diff --git a/app-laptop/tuxedo-keyboard/Manifest b/app-laptop/tuxedo-keyboard/Manifest
index 28b35f222a48..91f26106d86e 100644
--- a/app-laptop/tuxedo-keyboard/Manifest
+++ b/app-laptop/tuxedo-keyboard/Manifest
@@ -1,2 +1,3 @@
DIST tuxedo-keyboard-3.0.10.tar.gz 50759 BLAKE2B 08fec486f6555ff5b8de6b1ea49ce504747238284fda31b05686fd5955bf3bb3fc48b49c40b50c1bbdfcbf4af2f206a99f645b294ebceafec4c87751fd460090 SHA512 a3c5b74fc5587763f131a66f507c0b33d462ed87c8e05391152c09d1425b5e1771bfb08cc2d1e3bb73b02074f503d866ea463fd44fb06d00b38c6ac4cfcd4e3b
DIST tuxedo-keyboard-3.1.3.tar.gz 56532 BLAKE2B 06c2dec95e7888f765040bd41512c691cab9812fbea213b7766605aad6724adf3d5c6e5a3641621781f483e1ce249e71ea988b765e311d4bb4862997d8effb2c SHA512 dbad1ebc5d91d3306197012ce2fafa5e6063c9b8b62a14c3f1412c9340199c91500a6eeefbed73b1a5d15132dc4b4a73e11c86c15c1b2a3d44765b2664d2f331
+DIST tuxedo-keyboard-3.2.1.tar.gz 58606 BLAKE2B 5b358eea14db5f1ac595468e53cd39f026dc92203209c933df34a7d552dc5d9160fdd1d3867a87580518285ee5558fd983fb6b8c193362cde9ea1bf5689949be SHA512 35aaf129d3a75dd38107c2e20fdc066dc1161419a452716458d556b48dacfd42538bd36729a8f468ba838f7203cceeea24c5851de5bdae9c1b21d9d98f342a87
diff --git a/app-laptop/tuxedo-keyboard/files/tuxedo-keyboard-3.2.1-rm-unused-functions.patch b/app-laptop/tuxedo-keyboard/files/tuxedo-keyboard-3.2.1-rm-unused-functions.patch
new file mode 100755
index 000000000000..b8f8efae16b3
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/files/tuxedo-keyboard-3.2.1-rm-unused-functions.patch
@@ -0,0 +1,67 @@
+diff --git a/src/tuxedo_io/tuxedo_io.c b/src/tuxedo_io/tuxedo_io.c
+index 879efd7..5cf4f20 100644
+--- a/src/tuxedo_io/tuxedo_io.c
++++ b/src/tuxedo_io/tuxedo_io.c
+@@ -49,19 +49,6 @@ static u32 id_check_uniwill;
+
+ static struct uniwill_device_features_t *uw_feats;
+
+-/**
+- * strstr version of dmi_match
+- */
+-static bool dmi_string_in(enum dmi_field f, const char *str)
+-{
+- const char *info = dmi_get_system_info(f);
+-
+- if (info == NULL || str == NULL)
+- return info == str;
+-
+- return strstr(info, str) != NULL;
+-}
+-
+ static u32 clevo_identify(void)
+ {
+ return clevo_get_active_interface_id(NULL) == 0 ? 1 : 0;
+@@ -181,7 +168,7 @@ static long clevo_ioctl_interface(struct file *file, unsigned int cmd, unsigned
+
+ const char str_no_if[] = "";
+ char *str_clevo_if;
+-
++
+ switch (cmd) {
+ case R_CL_HW_IF_STR:
+ if (clevo_get_active_interface_id(&str_clevo_if) == 0) {
+@@ -814,7 +801,7 @@ static int __init tuxedo_io_init(void)
+ tuxedo_io_device_class = class_create(THIS_MODULE, "tuxedo_io");
+ device_create(tuxedo_io_device_class, NULL, tuxedo_io_device_handle, NULL, "tuxedo_io");
+ pr_debug("Module init successful\n");
+-
++
+ return 0;
+ }
+
+diff --git a/src/uniwill_keyboard.h b/src/uniwill_keyboard.h
+index 332acd6..859dc30 100644
+--- a/src/uniwill_keyboard.h
++++ b/src/uniwill_keyboard.h
+@@ -51,7 +51,6 @@
+ #define UNIWILL_OSD_TOUCHPADWORKAROUND 0xFFF
+
+ static void uw_charging_priority_write_state(void);
+-static void uw_charging_profile_write_state(void);
+
+ struct tuxedo_keyboard_driver uniwill_keyboard_driver;
+
+@@ -771,12 +770,6 @@ static int uw_has_charging_profile(bool *status)
+ return 0;
+ }
+
+-static void uw_charging_profile_write_state(void)
+-{
+- if (uw_charging_profile_loaded)
+- uw_set_charging_profile(uw_charging_profile_last_written_value);
+-}
+-
+ static void uw_charging_profile_init(struct platform_device *dev)
+ {
+ u8 value;
diff --git a/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.1.ebuild b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.1.ebuild
new file mode 100644
index 000000000000..2b59014a9c3e
--- /dev/null
+++ b/app-laptop/tuxedo-keyboard/tuxedo-keyboard-3.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CONFIG_CHECK="ACPI_WMI INPUT_SPARSEKMAP"
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo Keyboard"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-keyboard"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+PATCHES=( ${FILESDIR}/${PN}-${PV}-rm-unused-functions.patch )
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="clevo_acpi(tuxedo:${S}:src) clevo_wmi(tuxedo:${S}:src) uniwill_wmi(tuxedo:${S}:src) tuxedo_keyboard(tuxedo:${S}:src) tuxedo_io(tuxedo:${S}:src/tuxedo_io)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}