summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-26 16:10:13 +0000
committerSam James <sam@gentoo.org>2021-03-26 16:10:13 +0000
commit7c1f703583b083eca38fb4e7637be43b1a967837 (patch)
tree59aec415f647666cf686068b4bec881ba6bed12f /app-laptop
parentapp-laptop/laptop-mode-tools-1.74: Bumped ebuild, removed pm-utils. (diff)
downloadgentoo-7c1f703583b083eca38fb4e7637be43b1a967837.tar.gz
gentoo-7c1f703583b083eca38fb4e7637be43b1a967837.tar.bz2
gentoo-7c1f703583b083eca38fb4e7637be43b1a967837.zip
app-laptop/laptop-mode-tools: convert to tmpfiles.eclass
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/laptop-mode-tools/laptop-mode-tools-1.74.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.74.ebuild b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.74.ebuild
index 8eb88dc3d5ec..c90637e13ddb 100644
--- a/app-laptop/laptop-mode-tools/laptop-mode-tools-1.74.ebuild
+++ b/app-laptop/laptop-mode-tools/laptop-mode-tools-1.74.ebuild
@@ -1,32 +1,33 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils multilib systemd udev
+inherit optfeature systemd tmpfiles udev
MY_P="${PN}_${PV}"
DESCRIPTION="Linux kernel laptop_mode user-space utilities"
HOMEPAGE="https://github.com/rickysarraf/laptop-mode-tools/wiki"
SRC_URI="https://github.com/rickysarraf/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+acpi apm"
-RDEPEND="sys-apps/iproute2
+RDEPEND="
sys-apps/ethtool
+ sys-apps/iproute2
sys-apps/which
|| (
sys-apps/sdparm
sys-apps/hdparm
)
acpi? ( sys-power/acpid )
- apm? ( sys-apps/apmd )"
-
-S="${WORKDIR}/${MY_P}"
+ apm? ( sys-apps/apmd )
+"
src_compile() { :; }
@@ -40,20 +41,25 @@ src_install() {
TMPFILES_D="/usr/lib/tmpfiles.d" \
ACPI="$(usex acpi force disabled)" \
PMU="disabled" \
- APM="$(usex apm )" \
+ APM="$(usex apm)" \
SYSTEMD=yes \
sh ./install.sh || die
dodoc Documentation/*.txt README.md
newinitd "${FILESDIR}"/laptop_mode.init-1.4 laptop_mode
+ newtmpfiles "${S}"/etc/systemd/laptop-mode.conf.tmpfiles laptop-mode.conf
+
rm "${ED}/usr/lib/pm-utils/sleep.d/01laptop-mode" || die "could not remove PM utils config."
}
pkg_postinst() {
local daemon_name
optfeature "bluetooth support" net-wireless/bluez
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
+
+ tmpfiles_process laptop-mode.conf
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
if use acpi || use apm; then
if use acpi; then
daemon_name="acpid"