summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-27 11:01:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-27 11:01:15 +0000
commit7f9685828644dce80dd8afabe1a885a6b467718b (patch)
tree90193298ea937c3121c81bffe9380668ef54d177 /app-laptop
parentapp-portage/fquery: drop old (diff)
downloadgentoo-7f9685828644dce80dd8afabe1a885a6b467718b.tar.gz
gentoo-7f9685828644dce80dd8afabe1a885a6b467718b.tar.bz2
gentoo-7f9685828644dce80dd8afabe1a885a6b467718b.zip
app-laptop/pbbuttonsd: honor user's AR setting
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
index 8a17130c0544..f2e26d756df4 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1a.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools flag-o-matic
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Handles power management and special keys on laptops"
HOMEPAGE="http://pbbuttons.berlios.de"
@@ -74,15 +74,18 @@ src_compile() {
# Thanks to Stefan Bruda for this workaround
# Using -j1 fixes a parallel build issue with the docs
if use doc; then
- emake -j1
+ emake -j1 AR="$(tc-getAR)"
else
- emake
+ emake AR="$(tc-getAR)"
fi
}
src_install() {
dodir /etc/power
- use ibam && dodir /var/lib/ibam
+ if use ibam; then
+ dodir /var/lib/ibam
+ keepdir /var/lib/ibam
+ fi
default
@@ -93,8 +96,9 @@ src_install() {
use doc && dodoc -r doc/
dodir /etc/power/resume.d
+ keepdir /etc/power/resume.d
dodir /etc/power/suspend.d
- dodir /etc/power/scripts.d
+ keepdir /etc/power/suspend.d
exeinto /etc/power/scripts.d
doexe "${FILESDIR}"/wireless
ln -s "${D}"/etc/power/scripts.d/wireless "${D}"/etc/power/resume.d/wireless